summaryrefslogtreecommitdiffstats
path: root/spec.nix
diff options
context:
space:
mode:
Diffstat (limited to 'spec.nix')
-rw-r--r--spec.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/spec.nix b/spec.nix
new file mode 100644
index 0000000..47bdb8e
--- /dev/null
+++ b/spec.nix
@@ -0,0 +1,32 @@
1{ nixpkgs ? import <nixpkgs>, declInput }:
2
3let
4 pkgs = nixpkgs {
5 config = {};
6 };
7in {
8 jobsets = pkgs.runCommand "spec.json" {} ''
9 cat << EOF
10 ${builtins.toXML declInput}
11 EOF
12 cat > $out <<EOF
13 {
14 "master": {
15 "enabled": 1,
16 "hidden": false,
17 "description": "set_eq Master branch",
18 "nixexprinput": "src",
19 "nixexprpath": "default.nix",
20 "checkinterval": 60,
21 "schedulingshares": 1,
22 "enableemail": false,
23 "emailoverride": "",
24 "keepnr": 10,
25 "inputs": {
26 "src": { "type": "git", "value": "https://git.huh.gdn/set_eq/ master", "emailresponsible": true },
27 "nixpkgs": { "type": "git", "value": "https://github.com/nixos/nixpkgs-channels nixos-18.03", "emailresponsible": false }
28 }
29 }
30 EOF
31 '';
32}