summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMinijackson <minijackson@riseup.net>2021-05-20 20:18:33 +0200
committerMinijackson <minijackson@riseup.net>2021-05-20 20:18:33 +0200
commitcc67030828bf31728ddc5c7064bf0a88e0bbb88a (patch)
tree2ce1ebd14fbae27bd9257db85f1b0afc3298924b /Cargo.toml
parent557074fb6dadf89ddbfce11d67fe8cac0f9eed80 (diff)
downloadset_eq-cc67030828bf31728ddc5c7064bf0a88e0bbb88a.tar.gz
set_eq-cc67030828bf31728ddc5c7064bf0a88e0bbb88a.zip
update deps and nix, remove pa_eq as module is deprecated
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml10
1 files changed, 4 insertions, 6 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 54ff3b0..5871309 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -8,21 +8,19 @@ description = "A command-line tool to manipulate PulseAudio's equalizers"
8edition = "2018" 8edition = "2018"
9 9
10[features] 10[features]
11default = ["pa-eq", "pa-effects"] 11default = ["pa-effects"]
12 12
13pa-eq = ["dbus"]
14pa-effects = ["serde_json"] 13pa-effects = ["serde_json"]
15 14
16[dependencies] 15[dependencies]
17dbus = { version = "0.6", optional = true }
18failure = "0.1" 16failure = "0.1"
19lalrpop-util = "0.17" 17lalrpop-util = "0.19"
20log = "0.4" 18log = "0.4"
21pretty_env_logger = "0.3" 19pretty_env_logger = "0.4"
22regex = "1" 20regex = "1"
23serde_json = { version = "1", optional = true } 21serde_json = { version = "1", optional = true }
24structopt = "0.3" 22structopt = "0.3"
25 23
26[build-dependencies] 24[build-dependencies]
27lalrpop = "0.17" 25lalrpop = "0.19"
28structopt = "0.3" 26structopt = "0.3"