summaryrefslogtreecommitdiffstats
path: root/flake.nix
diff options
context:
space:
mode:
authorMinijackson <minijackson@riseup.net>2021-06-26 10:28:30 +0200
committerMinijackson <minijackson@riseup.net>2021-06-26 10:28:30 +0200
commitb85a4c978afaee5918a1032d84e42ac244d2059d (patch)
tree2f2a7c79882013898c686ae12140cd24ad09dc65 /flake.nix
downloadrobotnix-config-b85a4c978afaee5918a1032d84e42ac244d2059d.tar.gz
robotnix-config-b85a4c978afaee5918a1032d84e42ac244d2059d.zip
initial commit
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix50
1 files changed, 50 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..c493fe4
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,50 @@
1{
2 description = "A basic example robotnix configuration";
3
4 inputs.robotnix.url = "github:danielfullmer/robotnix";
5
6 outputs = { self, robotnix }: let
7 common = {
8 apps = {
9 bromite.enable = true;
10 fdroid.enable = true;
11 seedvault.enable = true;
12 };
13
14 microg.enable = true;
15
16 webview.bromite = {
17 enable = true;
18 availableByDefault = true;
19 };
20
21 # signing.enable = true;
22 # signing.keyStorePath = "/var/secrets/android-keys"; # A _string_ of the path for the key store.
23
24 # Build with ccache
25 ccache.enable = true;
26 };
27 in {
28 # "dailydriver" is an arbitrary user-chosen name for this particular
29 # configuration. Change it to something meaningful for you, perhaps just
30 # the device name if you only have one of this kind of device.
31 robotnixConfigurations.fp3 = robotnix.lib.robotnixSystem ({ config, pkgs, ... }: {
32 device = "FP3";
33 flavor = "lineageos";
34 } // common);
35
36 robotnixConfigurations.fp2 = robotnix.lib.robotnixSystem ({ config, pkgs, ... }: {
37 device = "FP2";
38 flavor = "lineageos";
39 } // common);
40
41 # This provides a convenient output which allows you to build the image by
42 # simply running "nix build" on this flake.
43 # Build other outputs with (for example): "nix build .#robotnixConfigurations.dailydriver.ota"
44 defaultPackage.x86_64-linux = self.robotnixConfigurations.fp3.img;
45
46 hydraJobs.robotnixConfigurations = {
47 inherit (self.robotnixConfigurations) fp2 fp3;
48 };
49 };
50}