summaryrefslogtreecommitdiffstats
path: root/flake.nix
diff options
context:
space:
mode:
authorMinijackson <minijackson@riseup.net>2021-11-04 10:45:06 +0100
committerMinijackson <minijackson@riseup.net>2021-11-04 10:45:06 +0100
commita777982b17ca555cb2a33e5828f8dc9cca302430 (patch)
tree7af0bdc41ec7eb19bed9c87b3886fd67060063d0 /flake.nix
parent1649317cb21c7fd30a5147cffdd1b24a6cef258a (diff)
downloadpandoc-nix-templates-a777982b17ca555cb2a33e5828f8dc9cca302430.tar.gz
pandoc-nix-templates-a777982b17ca555cb2a33e5828f8dc9cca302430.zip
factorize build instructions
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix18
1 files changed, 16 insertions, 2 deletions
diff --git a/flake.nix b/flake.nix
index ca5e3a4..f5ed111 100644
--- a/flake.nix
+++ b/flake.nix
@@ -1,7 +1,22 @@
1{ 1{
2 description = "My templates for making things with pandoc"; 2 description = "My templates for making things with pandoc";
3 3
4 outputs = { self, nixpkgs }: { 4 inputs.nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable";
5 inputs.beamertheme-metropolis = {
6 url = "github:matze/mtheme";
7 flake = false;
8 };
9 inputs.draculaTheme = {
10 url = "github:dracula/pygments";
11 flake = false;
12 };
13 inputs.pandoc-templates = {
14 url = "github:minijackson/pandoc-templates";
15 flake = false;
16 };
17
18 outputs = inputs @ { self, nixpkgs, beamertheme-metropolis, draculaTheme, pandoc-templates, }: {
19 overlay = import ./overlay.nix inputs;
5 20
6 templates = { 21 templates = {
7 beamer = { 22 beamer = {
@@ -11,6 +26,5 @@
11 }; 26 };
12 27
13 defaultTemplate = self.templates.beamer; 28 defaultTemplate = self.templates.beamer;
14
15 }; 29 };
16} 30}