summaryrefslogtreecommitdiffstats
path: root/templates/desktop/tinc.nix
diff options
context:
space:
mode:
Diffstat (limited to 'templates/desktop/tinc.nix')
-rw-r--r--templates/desktop/tinc.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/templates/desktop/tinc.nix b/templates/desktop/tinc.nix
new file mode 100644
index 0000000..9f4b365
--- /dev/null
+++ b/templates/desktop/tinc.nix
@@ -0,0 +1,16 @@
1{ config, ... }:
2
3{
4 topology.mainVpn = {
5 currentNodeIP = "<VPN IPv6 address>";
6 };
7
8 networking.interfaces."${config.topology.mainVpn.interfaceName}" = {
9 virtual = true;
10 virtualType = "tun";
11 ipv6.addresses = [ {
12 address = config.topology.mainVpn.currentNodeIP;
13 prefixLength = 64;
14 } ];
15 };
16}