diff options
Diffstat (limited to 'templates/desktop/flake.nix')
-rw-r--r-- | templates/desktop/flake.nix | 47 |
1 files changed, 47 insertions, 0 deletions
diff --git a/templates/desktop/flake.nix b/templates/desktop/flake.nix new file mode 100644 index 0000000..e0b2e40 --- /dev/null +++ b/templates/desktop/flake.nix | |||
@@ -0,0 +1,47 @@ | |||
1 | { | ||
2 | description = "Flake for the myHostname host"; | ||
3 | |||
4 | inputs.nixpkgs.url = "github:NixOS/nixpkgs/nixos-21.05"; | ||
5 | inputs.nixpkgs-unstable.url = "github:NixOS/nixpkgs"; | ||
6 | inputs.nixos-config-reborn = { | ||
7 | url = "git+https://git.huh.gdn/NixOS/nixos-config-reborn"; | ||
8 | inputs = { | ||
9 | nixpkgs.follows = "nixpkgs"; | ||
10 | nixpkgs-unstable.follows = "nixpkgs-unstable"; | ||
11 | }; | ||
12 | }; | ||
13 | inputs.nixos-hardware.url = "github:NixOS/nixos-hardware"; | ||
14 | |||
15 | outputs = inputs @ { self, nixpkgs, nixos-config-reborn, nixos-hardware, ... }: { | ||
16 | |||
17 | nixosConfigurations.myHostname = nixpkgs.lib.nixosSystem { | ||
18 | system = "x86_64-linux"; | ||
19 | modules = (with nixos-hardware.nixosModules; [ | ||
20 | common-cpu-intel | ||
21 | common-pc-ssd | ||
22 | ]) ++ (with nixos-config-reborn.nixosModules; [ | ||
23 | default | ||
24 | profiles.desktop | ||
25 | |||
26 | usecases.desktop.development | ||
27 | usecases.desktop.graphical.gaming | ||
28 | usecases.desktop.graphical.kodi | ||
29 | usecases.desktop.networkManager | ||
30 | ]) ++ [ | ||
31 | ./hardware-configuration.nix | ||
32 | |||
33 | ./boot.nix | ||
34 | ./host.nix | ||
35 | ./tinc.nix | ||
36 | |||
37 | ({ ... }: { | ||
38 | home-manager.users.minijackson.home.stateVersion = "21.05"; | ||
39 | home-manager.users.root.home.stateVersion = "21.05"; | ||
40 | |||
41 | system.stateVersion = "21.05"; | ||
42 | }) | ||
43 | ]; | ||
44 | }; | ||
45 | |||
46 | }; | ||
47 | } | ||