summaryrefslogtreecommitdiffstats
path: root/profiles/desktop.nix
diff options
context:
space:
mode:
Diffstat (limited to 'profiles/desktop.nix')
-rw-r--r--profiles/desktop.nix35
1 files changed, 35 insertions, 0 deletions
diff --git a/profiles/desktop.nix b/profiles/desktop.nix
new file mode 100644
index 0000000..2546b76
--- /dev/null
+++ b/profiles/desktop.nix
@@ -0,0 +1,35 @@
1inputs:
2
3{ pkgs, ... }:
4
5{
6 imports = [
7 inputs.self.nixosModules.usecases.desktop.default
8 ];
9
10 users.extraUsers.minijackson.packages = with pkgs; [
11 pass
12 tmuxp
13 taskwarrior
14 tokei
15 neofetch
16 ffmpeg
17 youtube-dl
18 pavucontrol
19 pandoc
20 poppler_utils
21 # TODO: on development workstation
22 /*
23 rr
24 rtags
25 gcc
26 clang
27 clang-tools
28 */
29 aspell
30 aspellDicts.en
31 aspellDicts.en-computers
32 aspellDicts.en-science
33 aspellDicts.fr
34 ];
35}