summaryrefslogtreecommitdiffstats
path: root/common/ssh.nix
diff options
context:
space:
mode:
Diffstat (limited to 'common/ssh.nix')
-rw-r--r--common/ssh.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/common/ssh.nix b/common/ssh.nix
new file mode 100644
index 0000000..8bdabc2
--- /dev/null
+++ b/common/ssh.nix
@@ -0,0 +1,15 @@
1inputs:
2
3{ config, pkgs, modulesPath, lib, ... }:
4
5{
6 programs.gnupg.agent = {
7 enable = true;
8 enableSSHSupport = true;
9 };
10
11 services.openssh = {
12 enable = true;
13 passwordAuthentication = false;
14 };
15}