diff options
Diffstat (limited to 'common/nixvim.nix')
-rw-r--r-- | common/nixvim.nix | 33 |
1 files changed, 32 insertions, 1 deletions
diff --git a/common/nixvim.nix b/common/nixvim.nix index a935c67..3f55c0f 100644 --- a/common/nixvim.nix +++ b/common/nixvim.nix | |||
@@ -22,7 +22,6 @@ inputs: | |||
22 | backup = true; | 22 | backup = true; |
23 | # Use `//` at the end to store the absolute file name | 23 | # Use `//` at the end to store the absolute file name |
24 | backupdir.__raw = "vim.fn.stdpath('data') .. '/backup//'"; | 24 | backupdir.__raw = "vim.fn.stdpath('data') .. '/backup//'"; |
25 | colorcolumn = "80"; | ||
26 | completeopt = [ | 25 | completeopt = [ |
27 | "menu" | 26 | "menu" |
28 | "menuone" | 27 | "menuone" |
@@ -531,6 +530,38 @@ inputs: | |||
531 | # TODO: maybe | 530 | # TODO: maybe |
532 | #refactoring.enable = true; | 531 | #refactoring.enable = true; |
533 | 532 | ||
533 | smartcolumn = { | ||
534 | enable = true; | ||
535 | settings = { | ||
536 | colorcolumn = "80"; | ||
537 | custom_colorcolumn = { | ||
538 | cpp = [ | ||
539 | "100" | ||
540 | "140" | ||
541 | ]; | ||
542 | java = [ | ||
543 | "100" | ||
544 | "140" | ||
545 | ]; | ||
546 | nix = [ | ||
547 | "100" | ||
548 | "120" | ||
549 | ]; | ||
550 | rust = [ | ||
551 | "80" | ||
552 | "100" | ||
553 | ]; | ||
554 | }; | ||
555 | disabled_filetypes = [ | ||
556 | "checkhealth" | ||
557 | "help" | ||
558 | "lspinfo" | ||
559 | "noice" | ||
560 | "Trouble" | ||
561 | ]; | ||
562 | }; | ||
563 | }; | ||
564 | |||
534 | spider = { | 565 | spider = { |
535 | enable = true; | 566 | enable = true; |
536 | keymaps.motions = { | 567 | keymaps.motions = { |