summaryrefslogtreecommitdiffstats
path: root/common/nixvim.nix
diff options
context:
space:
mode:
Diffstat (limited to 'common/nixvim.nix')
-rw-r--r--common/nixvim.nix14
1 files changed, 13 insertions, 1 deletions
diff --git a/common/nixvim.nix b/common/nixvim.nix
index 3ce41f1..e6bb937 100644
--- a/common/nixvim.nix
+++ b/common/nixvim.nix
@@ -488,7 +488,19 @@ in
488 488
489 diagnostics = { 489 diagnostics = {
490 deadnix.enable = true; 490 deadnix.enable = true;
491 statix.enable = true; 491 statix = {
492 enable = true;
493 settings.extra_args =
494 let
495 config = (pkgs.formats.toml { }).generate "statix.toml" {
496 disabled = [ "repeated_keys" ];
497 };
498 in
499 [
500 "-c"
501 "${config}"
502 ];
503 };
492 vale = { 504 vale = {
493 enable = true; 505 enable = true;
494 settings.extra_filetypes = [ 506 settings.extra_filetypes = [