summaryrefslogtreecommitdiffstats
path: root/common/nix.nix
diff options
context:
space:
mode:
Diffstat (limited to 'common/nix.nix')
-rw-r--r--common/nix.nix18
1 files changed, 13 insertions, 5 deletions
diff --git a/common/nix.nix b/common/nix.nix
index e31bcbf..0e58908 100644
--- a/common/nix.nix
+++ b/common/nix.nix
@@ -1,8 +1,8 @@
1inputs: 1inputs: {
2 2 config,
3{ pkgs, ... }: 3 lib,
4 4 ...
5{ 5}: {
6 nix = { 6 nix = {
7 gc = { 7 gc = {
8 automatic = true; 8 automatic = true;
@@ -14,5 +14,13 @@ inputs:
14 auto-optimise-store = true; 14 auto-optimise-store = true;
15 extra-experimental-features = ["nix-command" "flakes"]; 15 extra-experimental-features = ["nix-command" "flakes"];
16 }; 16 };
17
18 registry = lib.mapAttrs (_name: value: {flake = value;}) inputs;
19 nixPath =
20 lib.mapAttrsToList
21 (name: value: "${name}=${value.flake}")
22 (lib.filterAttrs
23 (name: value: name != "self" && value.flake != null)
24 config.nix.registry);
17 }; 25 };
18} 26}