summaryrefslogtreecommitdiffstats
path: root/common/nix.nix
diff options
context:
space:
mode:
Diffstat (limited to 'common/nix.nix')
-rw-r--r--common/nix.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/common/nix.nix b/common/nix.nix
new file mode 100644
index 0000000..f16e1d9
--- /dev/null
+++ b/common/nix.nix
@@ -0,0 +1,19 @@
1inputs:
2
3{ pkgs, ... }:
4
5{
6 nix = {
7 autoOptimiseStore = true;
8 gc = {
9 automatic = true;
10 dates = "03:15";
11 options = "--delete-older-than 30d";
12 };
13
14 package = pkgs.nixFlakes;
15 extraOptions = ''
16 experimental-features = nix-command flakes
17 '';
18 };
19}