summaryrefslogtreecommitdiffstats
path: root/common/commandline/zsh.nix
diff options
context:
space:
mode:
Diffstat (limited to 'common/commandline/zsh.nix')
-rw-r--r--common/commandline/zsh.nix13
1 files changed, 7 insertions, 6 deletions
diff --git a/common/commandline/zsh.nix b/common/commandline/zsh.nix
index d1fdee7..aba2d94 100644
--- a/common/commandline/zsh.nix
+++ b/common/commandline/zsh.nix
@@ -4,12 +4,13 @@ inputs: {
4 pkgs, 4 pkgs,
5 ... 5 ...
6}: 6}:
7with inputs.self.lib.theme; let 7let
8 inherit (inputs.self.lib.theme) fgEscapeCode;
8 dominantEscapeCode = fgEscapeCode config.theme.colors.dominant; 9 dominantEscapeCode = fgEscapeCode config.theme.colors.dominant;
9in { 10in {
10 nixpkgs.overlays = [ 11 nixpkgs.overlays = [
11 (final: prev: { 12 (_final: prev: {
12 zsh = prev.zsh.overrideAttrs (old: { 13 zsh = prev.zsh.overrideAttrs (_old: {
13 configureFlags = [ 14 configureFlags = [
14 "--enable-maildir-support" 15 "--enable-maildir-support"
15 "--enable-multibyte" 16 "--enable-multibyte"
@@ -26,7 +27,7 @@ in {
26 programs.zsh = { 27 programs.zsh = {
27 enable = true; 28 enable = true;
28 29
29 interactiveShellInit = with lib; '' 30 interactiveShellInit = ''
30 source "${pkgs.grml-zsh-config}/etc/zsh/zshrc" 31 source "${pkgs.grml-zsh-config}/etc/zsh/zshrc"
31 is4 && xsource "${pkgs.grml-zsh-config}/etc/zsh/keephack" 32 is4 && xsource "${pkgs.grml-zsh-config}/etc/zsh/keephack"
32 33
@@ -43,8 +44,8 @@ in {
43 } 44 }
44 45
45 # Grml's ZSH config overrides less variables 46 # Grml's ZSH config overrides less variables
46 export ${concatStringsSep " " 47 export ${lib.concatStringsSep " "
47 (mapAttrsToList 48 (lib.mapAttrsToList
48 (variable: value: "${variable}=\"${value}\"") 49 (variable: value: "${variable}=\"${value}\"")
49 config.programs.less.envVariables)} 50 config.programs.less.envVariables)}
50 ''; 51 '';