summaryrefslogtreecommitdiffstats
path: root/common/commandline/starship.nix
diff options
context:
space:
mode:
Diffstat (limited to 'common/commandline/starship.nix')
-rw-r--r--common/commandline/starship.nix13
1 files changed, 7 insertions, 6 deletions
diff --git a/common/commandline/starship.nix b/common/commandline/starship.nix
index 1683765..5983d2e 100644
--- a/common/commandline/starship.nix
+++ b/common/commandline/starship.nix
@@ -2,20 +2,21 @@ inputs: {lib, ...}: {
2 home-manager.users.minijackson = { 2 home-manager.users.minijackson = {
3 programs.starship = { 3 programs.starship = {
4 enable = true; 4 enable = true;
5 enableZshIntegration = false; 5 enableZshIntegration = true;
6 6
7 settings = lib.mkMerge [ 7 settings = lib.mkMerge [
8 { 8 {
9 directory = { 9 directory = {
10 fish_style_pwd_dir_length = 2; 10 fish_style_pwd_dir_length = 2;
11 style = "bold blue"; 11 repo_root_style = "bold cyan";
12 style = "bold white";
13 truncate_to_repo = false;
12 }; 14 };
15
13 jobs.symbol = "+ "; 16 jobs.symbol = "+ ";
17
14 nix_shell.style = "bold blue"; 18 nix_shell.style = "bold blue";
15 package = { 19 package.style = "bold green";
16 disabled = true;
17 style = "bold green";
18 };
19 rust.style = "bold dimmed yellow"; 20 rust.style = "bold dimmed yellow";
20 } 21 }
21 22