summaryrefslogtreecommitdiffstats
path: root/common/commandline/git.nix
diff options
context:
space:
mode:
Diffstat (limited to 'common/commandline/git.nix')
-rw-r--r--common/commandline/git.nix13
1 files changed, 0 insertions, 13 deletions
diff --git a/common/commandline/git.nix b/common/commandline/git.nix
index 9cb07df..ca8a745 100644
--- a/common/commandline/git.nix
+++ b/common/commandline/git.nix
@@ -1,19 +1,6 @@
1_inputs: 1_inputs:
2{ config, pkgs, ... }: 2{ config, pkgs, ... }:
3{ 3{
4 environment = {
5 systemPackages = with pkgs; [
6 unstable.git-branchless
7 unstable.gitoxide
8 watchman
9 ];
10 shellAliases.git = "git-branchless wrap --";
11 };
12
13 programs.zsh.interactiveShellInit = ''
14 source ${../../dotfiles/git-branchless.zsh}
15 '';
16
17 home-manager.sharedModules = [ 4 home-manager.sharedModules = [
18 { 5 {
19 programs.git = { 6 programs.git = {