summaryrefslogtreecommitdiffstats
path: root/common/commandline/git.nix
diff options
context:
space:
mode:
Diffstat (limited to 'common/commandline/git.nix')
-rw-r--r--common/commandline/git.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/common/commandline/git.nix b/common/commandline/git.nix
index 2a2abcf..05785ed 100644
--- a/common/commandline/git.nix
+++ b/common/commandline/git.nix
@@ -33,6 +33,21 @@ _inputs:
33 { 33 {
34 init.defaultBranch = "master"; 34 init.defaultBranch = "master";
35 35
36 color = {
37 branch = {
38 current = "magenta";
39 local = "green";
40 remote = "red";
41 };
42 status = {
43 branch = "magenta";
44 localBranch = "magenta";
45 remoteBranch = "red";
46 };
47 };
48
49 commit.verbose = true;
50
36 core = { 51 core = {
37 whitespace = "trailing-space,space-before-tab"; 52 whitespace = "trailing-space,space-before-tab";
38 pager = deltaCommand; 53 pager = deltaCommand;