summaryrefslogtreecommitdiffstats
path: root/usecases/desktop/graphical.nix
diff options
context:
space:
mode:
authorMinijackson <minijackson@riseup.net>2021-04-18 16:58:23 +0200
committerMinijackson <minijackson@riseup.net>2021-04-18 16:58:23 +0200
commit8ffe5ce23fa1548304a3fa25f2bd0e89837f5a0b (patch)
treecd0de6a4642b76b42002dae5291c307d30727bc6 /usecases/desktop/graphical.nix
parent46ac3d5464712d6b0e0bee4ac62543abcbf2db2c (diff)
downloadnixos-config-reborn-8ffe5ce23fa1548304a3fa25f2bd0e89837f5a0b.tar.gz
nixos-config-reborn-8ffe5ce23fa1548304a3fa25f2bd0e89837f5a0b.zip
revamp with nix flakes + desktop config
Diffstat (limited to 'usecases/desktop/graphical.nix')
-rw-r--r--usecases/desktop/graphical.nix73
1 files changed, 73 insertions, 0 deletions
diff --git a/usecases/desktop/graphical.nix b/usecases/desktop/graphical.nix
new file mode 100644
index 0000000..29b2db6
--- /dev/null
+++ b/usecases/desktop/graphical.nix
@@ -0,0 +1,73 @@
1inputs:
2
3{ pkgs, ... }:
4
5{
6 imports = [
7 (import ./pipewire.nix inputs)
8
9 (import ./graphical/alacritty.nix inputs)
10 (import ./graphical/mpv.nix inputs)
11 (import ./graphical/rofi.nix inputs)
12 (import ./graphical/sway.nix inputs)
13 (import ./graphical/waybar.nix inputs)
14 (import ./graphical/zathura.nix inputs)
15 ];
16
17 fonts = {
18 enableDefaultFonts = true;
19 fonts = with pkgs; [
20 fira
21 fira-mono
22 dejavu_fonts
23 freefont_ttf
24 liberation_ttf
25 noto-fonts-cjk
26 #fira-mono-italic
27 lmodern
28 # Symbols
29 unifont
30 siji
31 font-awesome_5
32 #joypixels
33 # Collections
34 league-of-moveable-type
35 ];
36
37 fontconfig = {
38 #ultimate.enable = true;
39
40 defaultFonts = {
41 serif = [ "DejaVu Serif" ];
42 sansSerif = [ "DejaVu Sans" ];
43 monospace = [ "Fira Mono" ];
44 #emoji = [ "JoyPixels" ];
45 };
46 };
47 };
48
49 hardware.opengl.enable = true;
50 programs.dconf.enable = true;
51
52 xdg = {
53 sounds.enable = true;
54 portal = {
55 enable = true;
56 extraPortals = with pkgs; [
57 xdg-desktop-portal-gtk
58 ];
59 gtkUsePortal = true;
60 };
61 };
62
63 # For KDEConnect
64 networking.firewall.allowedTCPPortRanges = [{ from = 1714; to = 1764; }];
65 networking.firewall.allowedUDPPortRanges = [{ from = 1714; to = 1764; }];
66
67 home-manager.users.minijackson = {
68 services.kdeconnect = {
69 enable = true;
70 indicator = true;
71 };
72 };
73}