summaryrefslogtreecommitdiffstats
path: root/usecases/desktop/graphical.nix
diff options
context:
space:
mode:
authorMinijackson <minijackson@riseup.net>2022-12-04 15:07:44 +0100
committerMinijackson <minijackson@riseup.net>2022-12-04 15:07:44 +0100
commit65a77c9149e612590276af4ca6052f6453ada84a (patch)
treefce42c3a7088e5681fa2257b6e2eaf56ad30b0a2 /usecases/desktop/graphical.nix
parent51f2c7087fadbb1de17a5e59496efef1a5cf85b7 (diff)
downloadnixos-config-reborn-65a77c9149e612590276af4ca6052f6453ada84a.tar.gz
nixos-config-reborn-65a77c9149e612590276af4ca6052f6453ada84a.zip
graphical: workaround libadwaita, pull theme from master
Diffstat (limited to 'usecases/desktop/graphical.nix')
-rw-r--r--usecases/desktop/graphical.nix35
1 files changed, 23 insertions, 12 deletions
diff --git a/usecases/desktop/graphical.nix b/usecases/desktop/graphical.nix
index 2d1c3ae..e82b953 100644
--- a/usecases/desktop/graphical.nix
+++ b/usecases/desktop/graphical.nix
@@ -105,7 +105,12 @@ inputs: {
105 } 105 }
106 ]; 106 ];
107 107
108 home-manager.users.minijackson = { 108 home-manager.users.minijackson = let
109 color =
110 if config.theme.colors.dominantName == "cyan"
111 then "teal"
112 else config.theme.colors.dominantName;
113 in {
109 gtk = { 114 gtk = {
110 enable = true; 115 enable = true;
111 iconTheme = { 116 iconTheme = {
@@ -115,17 +120,21 @@ inputs: {
115 }; 120 };
116 name = "Tela-circle-brown-dark"; 121 name = "Tela-circle-brown-dark";
117 }; 122 };
118 theme = let 123 theme = {
119 color = 124 package =
120 if config.theme.colors.dominantName == "cyan" 125 (pkgs.unstable.graphite-gtk-theme.overrideAttrs (_old: {
121 then "teal" 126 src = pkgs.fetchFromGitHub {
122 else config.theme.colors.dominantName; 127 owner = "vinceliuice";
123 in { 128 repo = "graphite-gtk-theme";
124 package = pkgs.unstable.graphite-gtk-theme.override { 129 rev = "a65fbec34f1ba1e9c7f7a86afc7c02d2210a11a4";
125 themeVariants = [color]; 130 hash = "sha256-aJMSLWVDqsAx+3QYAAhGKddEaformlK28M7YSJ/v7sU=";
126 sizeVariants = ["compact"]; 131 };
127 tweaks = ["normal" "rimless"]; 132 }))
128 }; 133 .override {
134 themeVariants = [color];
135 sizeVariants = ["compact"];
136 tweaks = ["normal" "rimless"];
137 };
129 name = "Graphite-${color}-Dark-compact"; 138 name = "Graphite-${color}-Dark-compact";
130 }; 139 };
131 140
@@ -134,6 +143,8 @@ inputs: {
134 }; 143 };
135 }; 144 };
136 145
146 home.sessionVariables.GTK_THEME = "Graphite-${color}-Dark-compact";
147
137 services.kdeconnect = { 148 services.kdeconnect = {
138 enable = true; 149 enable = true;
139 indicator = true; 150 indicator = true;