summaryrefslogtreecommitdiffstats
path: root/flake.nix
diff options
context:
space:
mode:
authorMinijackson <minijackson@riseup.net>2021-06-10 08:50:04 +0200
committerMinijackson <minijackson@riseup.net>2021-06-10 08:50:04 +0200
commit3e5ae96919582226dfc7f7e42231b0c7a63dfb45 (patch)
treec41d0c7c45cd9afdab8850c9e3fade4a41797bde /flake.nix
parent9dd5a0f9a9d9bdb118042e2413e24e023d513b0a (diff)
downloadnixos-config-reborn-3e5ae96919582226dfc7f7e42231b0c7a63dfb45.tar.gz
nixos-config-reborn-3e5ae96919582226dfc7f7e42231b0c7a63dfb45.zip
flake: less hacky usage of nixos tests
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix12
1 files changed, 6 insertions, 6 deletions
diff --git a/flake.nix b/flake.nix
index f093e14..689dbb4 100644
--- a/flake.nix
+++ b/flake.nix
@@ -155,7 +155,7 @@
155 self.nixosModules.default 155 self.nixosModules.default
156 ({ modulesPath, ... }: { 156 ({ modulesPath, ... }: {
157 imports = [ 157 imports = [
158 (modulesPath + "/installer/cd-dvd/installation-cd-base.nix") 158 (modulesPath + "/installer/cd-dvd/installation-cd-base.nix")
159 ]; 159 ];
160 160
161 isoImage.makeEfiBootable = true; 161 isoImage.makeEfiBootable = true;
@@ -173,11 +173,11 @@
173 173
174 hydraJobs = 174 hydraJobs =
175 let 175 let
176 testing = import (nixpkgs + "/nixos/lib/testing-python.nix") { system = "x86_64-linux"; }; 176 inherit (nixpkgs.legacyPackages.x86_64-linux) nixosTest;
177 in 177 in
178 { 178 {
179 179
180 tests.testDefault = testing.simpleTest { 180 tests.testDefault = nixosTest {
181 machine = self.nixosModules.test; 181 machine = self.nixosModules.test;
182 testScript = '' 182 testScript = ''
183 # TODO 183 # TODO
@@ -185,7 +185,7 @@
185 ''; 185 '';
186 }; 186 };
187 187
188 tests.testPlainDesktop = testing.simpleTest { 188 tests.testPlainDesktop = nixosTest {
189 machine = { ... }: { 189 machine = { ... }: {
190 imports = [ 190 imports = [
191 self.nixosModules.test 191 self.nixosModules.test
@@ -199,7 +199,7 @@
199 ''; 199 '';
200 }; 200 };
201 201
202 tests.testDevDesktop = testing.simpleTest { 202 tests.testDevDesktop = nixosTest {
203 machine = { ... }: { 203 machine = { ... }: {
204 imports = [ 204 imports = [
205 self.nixosModules.test 205 self.nixosModules.test
@@ -214,7 +214,7 @@
214 ''; 214 '';
215 }; 215 };
216 216
217 tests.testServer = testing.simpleTest { 217 tests.testServer = nixosTest {
218 machine = { ... }: { 218 machine = { ... }: {
219 imports = [ 219 imports = [
220 self.nixosModules.test 220 self.nixosModules.test