diff options
author | Minijackson <minijackson@riseup.net> | 2020-12-03 16:45:06 +0100 |
---|---|---|
committer | Minijackson <minijackson@riseup.net> | 2020-12-03 16:45:06 +0100 |
commit | 3f0e83cb4816e637d8c916fb77217e1c5824dbe5 (patch) | |
tree | 65b48ffe6e82459cde97b8ee61a597402ba2617b /configuration.nix | |
download | nixos-config-reborn-3f0e83cb4816e637d8c916fb77217e1c5824dbe5.tar.gz nixos-config-reborn-3f0e83cb4816e637d8c916fb77217e1c5824dbe5.zip |
initial commit: most of previous configuration reworked
Diffstat (limited to 'configuration.nix')
-rw-r--r-- | configuration.nix | 72 |
1 files changed, 72 insertions, 0 deletions
diff --git a/configuration.nix b/configuration.nix new file mode 100644 index 0000000..1a5530f --- /dev/null +++ b/configuration.nix | |||
@@ -0,0 +1,72 @@ | |||
1 | # Edit this configuration file to define what should be installed on | ||
2 | # your system. Help is available in the configuration.nix(5) man page | ||
3 | # and in the NixOS manual (accessible by running ‘nixos-help’). | ||
4 | |||
5 | { config, pkgs, modulesPath, ... }: | ||
6 | |||
7 | { | ||
8 | imports = [ | ||
9 | ./hardware-configuration.nix | ||
10 | ./host-secret.nix | ||
11 | ./common/default.nix | ||
12 | ]; | ||
13 | |||
14 | # Set your time zone. | ||
15 | time.timeZone = "Europe/Paris"; | ||
16 | |||
17 | # Select internationalisation properties. | ||
18 | i18n.defaultLocale = "en_US.UTF-8"; | ||
19 | # console = { | ||
20 | # font = "Lat2-Terminus16"; | ||
21 | # keyMap = "us"; | ||
22 | # }; | ||
23 | |||
24 | # List packages installed in system profile. To search, run: | ||
25 | # $ nix search wget | ||
26 | environment.systemPackages = with pkgs; [ | ||
27 | wget | ||
28 | vim tmux | ||
29 | ripgrep file progress psmisc lsof nethogs | ||
30 | fd tree ncdu | ||
31 | lm_sensors hddtemp smartmontools | ||
32 | elinks | ||
33 | wipe | ||
34 | gnupg | ||
35 | nix-prefetch-scripts | ||
36 | shellcheck | ||
37 | ]; | ||
38 | |||
39 | # Some programs need SUID wrappers, can be configured further or are | ||
40 | # started in user sessions. | ||
41 | # programs.mtr.enable = true; | ||
42 | # programs.gnupg.agent = { | ||
43 | # enable = true; | ||
44 | # enableSSHSupport = true; | ||
45 | # }; | ||
46 | |||
47 | # List services that you want to enable: | ||
48 | |||
49 | # Enable the OpenSSH daemon. | ||
50 | services.openssh = { | ||
51 | enable = true; | ||
52 | passwordAuthentication = false; | ||
53 | }; | ||
54 | |||
55 | # Define a user account. Don't forget to set a password with ‘passwd’. | ||
56 | users.extraUsers.minijackson = { | ||
57 | isNormalUser = true; | ||
58 | extraGroups = [ "users" "wheel" ]; | ||
59 | openssh.authorizedKeys.keys = ["ssh-rsa AAAAB3NzaC1yc2EAAAADAQABAAACAQCmyjB5yuU8GK3ZVFznELVEwXN7zzjQJcPYZ89YCGTANjPHpHxZv5R9/kgjTtIKrqqHdTvfr8V8sao9Nr7PhtcV9UywrFn+kplyGf9WDl2oDF9eZprX3beR9zwDj/YIcFRx3wXk4JK/ioZJjcVZ3+xWPixiFplvHIyMsTjKfgRplntHpvoyLM8vURjLOCdPr6SRPReVXuSR2DRlVO7q7y+4FwA1FKAndg9YACoM1g2bEJ6eGyCPp2kFde+GvMv1y6FlBS1OFddGmBpUJzJ4mQ4ebqDVFsKQMx1xCkiz0l7tfVpXqXToHF+baTESEKbC4654PunD99BC0J4otHKrerdmX0HdTgHKtAnslSwRD5NZVAojk/CR3DiSQYFSO9OhFVjHNQsc1zpoKPtJYMe1ax3pcvc+XLCrKLUdHH8x9rVGefZXwIyLrrGrB7fVlyIyX7j04dNALQZiuFOKCInaYypVLHLy0k+buhQlVqKCS6N1xP5O6JiWUKXFYYyoRmSoX9+bfPiwsMrPL+rYXkee0K67BI1NiFAYPmdFFM0jtdFaYuvgEAWw7b9WyWyO/JAdHRwtlqfAqraPBrb4sldvQfLBm8RdORBYMaVbg4EUKMOJjIeAAK+7xWPtg2XeJNnsje/IsWaVXIBx2IAC50uAnIZ/ksw5lyAZP+HyGIHhCAQChQ== minijackson@riseup.net"]; | ||
60 | }; | ||
61 | |||
62 | nix = { | ||
63 | autoOptimiseStore = true; | ||
64 | gc = { | ||
65 | automatic = true; | ||
66 | dates = "03:15"; | ||
67 | options = "--delete-older-than 30d"; | ||
68 | }; | ||
69 | }; | ||
70 | |||
71 | system.autoUpgrade.enable = true; | ||
72 | } | ||