diff options
author | Minijackson <minijackson@riseup.net> | 2024-09-25 21:46:27 +0200 |
---|---|---|
committer | Minijackson <minijackson@riseup.net> | 2024-09-25 21:46:27 +0200 |
commit | 57b7a0738b32afd562e28abc52a1b29aaed8b031 (patch) | |
tree | 152c30141f693bb2a8c8e8243a682517e9a7afc0 /common/nixvim.nix | |
parent | 6a5b07ce5f451045f203ec825ce497c5cb6c43b3 (diff) | |
download | nixos-config-reborn-57b7a0738b32afd562e28abc52a1b29aaed8b031.tar.gz nixos-config-reborn-57b7a0738b32afd562e28abc52a1b29aaed8b031.zip |
common/nixvim: fmt
Diffstat (limited to 'common/nixvim.nix')
-rw-r--r-- | common/nixvim.nix | 30 |
1 files changed, 25 insertions, 5 deletions
diff --git a/common/nixvim.nix b/common/nixvim.nix index 68a4905..46c0a12 100644 --- a/common/nixvim.nix +++ b/common/nixvim.nix | |||
@@ -204,28 +204,44 @@ in | |||
204 | 204 | ||
205 | { | 205 | { |
206 | key = "<Space>"; | 206 | key = "<Space>"; |
207 | mode = ["n" "x" "o"]; | 207 | mode = [ |
208 | "n" | ||
209 | "x" | ||
210 | "o" | ||
211 | ]; | ||
208 | action = "<Plug>(leap-forward)"; | 212 | action = "<Plug>(leap-forward)"; |
209 | options.desc = "Leap forward to"; | 213 | options.desc = "Leap forward to"; |
210 | } | 214 | } |
211 | 215 | ||
212 | { | 216 | { |
213 | key = "<C-Space>"; | 217 | key = "<C-Space>"; |
214 | mode = ["n" "x" "o"]; | 218 | mode = [ |
219 | "n" | ||
220 | "x" | ||
221 | "o" | ||
222 | ]; | ||
215 | action = "<Plug>(leap-backward)"; | 223 | action = "<Plug>(leap-backward)"; |
216 | options.desc = "Leap backward to"; | 224 | options.desc = "Leap backward to"; |
217 | } | 225 | } |
218 | 226 | ||
219 | { | 227 | { |
220 | key = "g<Space>"; | 228 | key = "g<Space>"; |
221 | mode = ["n" "x" "o"]; | 229 | mode = [ |
230 | "n" | ||
231 | "x" | ||
232 | "o" | ||
233 | ]; | ||
222 | action = "<Plug>(leap-from-window)"; | 234 | action = "<Plug>(leap-from-window)"; |
223 | options.desc = "Leap from window"; | 235 | options.desc = "Leap from window"; |
224 | } | 236 | } |
225 | 237 | ||
226 | { | 238 | { |
227 | key = "gnn"; | 239 | key = "gnn"; |
228 | mode = ["n" "x" "o"]; | 240 | mode = [ |
241 | "n" | ||
242 | "x" | ||
243 | "o" | ||
244 | ]; | ||
229 | action.__raw = '' | 245 | action.__raw = '' |
230 | function() | 246 | function() |
231 | require('leap.treesitter').select() | 247 | require('leap.treesitter').select() |
@@ -236,7 +252,11 @@ in | |||
236 | 252 | ||
237 | { | 253 | { |
238 | key = "gnN"; | 254 | key = "gnN"; |
239 | mode = ["n" "x" "o"]; | 255 | mode = [ |
256 | "n" | ||
257 | "x" | ||
258 | "o" | ||
259 | ]; | ||
240 | action = "V<cmd>lua require('leap.treesitter').select()<cr>"; | 260 | action = "V<cmd>lua require('leap.treesitter').select()<cr>"; |
241 | options.desc = "Start linewise incremental selection"; | 261 | options.desc = "Start linewise incremental selection"; |
242 | } | 262 | } |