summaryrefslogtreecommitdiffstats
path: root/common/commandline/htop.nix
diff options
context:
space:
mode:
authorMinijackson <minijackson@riseup.net>2020-12-03 16:45:06 +0100
committerMinijackson <minijackson@riseup.net>2020-12-03 16:45:06 +0100
commit3f0e83cb4816e637d8c916fb77217e1c5824dbe5 (patch)
tree65b48ffe6e82459cde97b8ee61a597402ba2617b /common/commandline/htop.nix
downloadnixos-config-reborn-3f0e83cb4816e637d8c916fb77217e1c5824dbe5.tar.gz
nixos-config-reborn-3f0e83cb4816e637d8c916fb77217e1c5824dbe5.zip
initial commit: most of previous configuration reworked
Diffstat (limited to 'common/commandline/htop.nix')
-rw-r--r--common/commandline/htop.nix44
1 files changed, 44 insertions, 0 deletions
diff --git a/common/commandline/htop.nix b/common/commandline/htop.nix
new file mode 100644
index 0000000..f9732a6
--- /dev/null
+++ b/common/commandline/htop.nix
@@ -0,0 +1,44 @@
1{ config, ... }:
2
3{
4 home-manager.users.minijackson = { ... }:
5 {
6 programs.htop = {
7 enable = true;
8
9 fields = [
10 "PID" "USER"
11 "PRIORITY" "NICE"
12 "STATE"
13 "IO_PRIORITY" "IO_READ_RATE" "IO_WRITE_RATE"
14 "PERCENT_CPU" "PERCENT_MEM"
15 "TIME"
16 "COMM"
17 ];
18
19 hideThreads = true;
20 hideUserlandThreads = true;
21 showThreadNames = true;
22 shadowOtherUsers = true;
23
24 highlightBaseName = true;
25
26 # On NixOS? NO.
27 showProgramPath = false;
28
29 treeView = true;
30
31 meters = {
32 left = [ "LeftCPUs2" "Memory" "Swap" "Blank" { kind = "Battery"; mode = 1; } ];
33 right = [ "RightCPUs2" "Blank" "Tasks" "LoadAverage" "Uptime" ];
34 };
35 };
36 };
37
38 home-manager.users.root = { ... }:
39 {
40 programs.htop = config.home-manager.users.minijackson.programs.htop // {
41 shadowOtherUsers = false;
42 };
43 };
44}