summaryrefslogtreecommitdiffstats
path: root/common/commandline.nix
diff options
context:
space:
mode:
authorMinijackson <minijackson@riseup.net>2024-11-09 08:55:03 +0100
committerMinijackson <minijackson@riseup.net>2024-11-09 08:55:03 +0100
commit135ab5847ab24b25b1ef4c58ab629f2f0b6b8d18 (patch)
tree796670ae441772916c193f520396fbf69a1cdaed /common/commandline.nix
parent6c40e37ba0aeb9e87e5c526e564c46aca6f121c6 (diff)
downloadnixos-config-reborn-135ab5847ab24b25b1ef4c58ab629f2f0b6b8d18.tar.gz
nixos-config-reborn-135ab5847ab24b25b1ef4c58ab629f2f0b6b8d18.zip
common/commandline: properly clear standout escape code
and set bold attribute for bold
Diffstat (limited to 'common/commandline.nix')
-rw-r--r--common/commandline.nix13
1 files changed, 12 insertions, 1 deletions
diff --git a/common/commandline.nix b/common/commandline.nix
index 6025aaa..2ff6291 100644
--- a/common/commandline.nix
+++ b/common/commandline.nix
@@ -92,9 +92,20 @@ in {
92 # -J: display status column at left edge of screen 92 # -J: display status column at left edge of screen
93 # -F: quit if one screen 93 # -F: quit if one screen
94 LESS = "-W -z-4 -R -J -F"; 94 LESS = "-W -z-4 -R -J -F";
95
96 # Blink
95 LESS_TERMCAP_mb = dominantEscapeCode; 97 LESS_TERMCAP_mb = dominantEscapeCode;
96 LESS_TERMCAP_md = dominantEscapeCode; 98
99 # Bold
100 # tput bold
101 LESS_TERMCAP_md = dominantEscapeCode + "";
102
103 # Standout start
97 LESS_TERMCAP_so = bgDominantEscapeCode + backgroundEscapeCode; 104 LESS_TERMCAP_so = bgDominantEscapeCode + backgroundEscapeCode;
105 # Standout end
106 # Turn off all attributes
107 # tput sgr0
108 LESS_TERMCAP_se = "";
98 }; 109 };
99 }; 110 };
100 111