summaryrefslogtreecommitdiffstats
path: root/examples/imapresource/imapresource.h
Commit message (Collapse)AuthorAge
* Adapt to KAsync changesChristian Mollekopf2017-03-01
|
* Moved inspection commands to a separate inspector.Christian Mollekopf2016-11-28
|
* CleanupChristian Mollekopf2016-11-27
|
* Specify the resource name in one placeChristian Mollekopf2016-10-21
|
* Refactor how the storage is used.Christian Mollekopf2016-10-21
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | This is the initial refactoring to improve how we deal with the storage. It does a couple of things: * Rename Sink::Storage to Sink::Storage::DataStore to free up the Sink::Storage namespace * Introduce a Sink::ResourceContext to have a single object that can be passed around containing everything that is necessary to operate on a resource. This is a lot better than the multiple separate parameters that we used to pass around all over the place, while still allowing for dependency injection for tests. * Tie storage access together using the new EntityStore that directly works with ApplicationDomainTypes. This gives us a central place where main storage, indexes and buffer adaptors are tied together, which will also give us a place to implement external indexes, such as a fulltextindex using xapian. * Use ApplicationDomainTypes as the default way to pass around entities. Instead of using various ways to pass around entities (buffers, buffer adaptors, ApplicationDomainTypes), only use a single way. The old approach was confusing, and was only done as: * optimization; really shouldn't be necessary and otherwise I'm sure we can find better ways to optimize ApplicationDomainType itself. * a way to account for entities that have multiple buffers, a concept that I no longer deem relevant. While this commit does the bulk of the work to get there, the following commits will refactor more stuff to get things back to normal.
* Avoid using the resource object to remove the data from disk.Christian Mollekopf2016-10-07
| | | | | ...because creating it will potentially start transactions on the database we're about to remove.
* Shorten the types to be more distinctive.Christian Mollekopf2016-07-08
| | | | | The org.kde prefix is useless and possibly misleading. Simply prefixing with sink is more unique and shorter.
* The imap resource is backChristian Mollekopf2016-05-29
|
* Message removalsChristian Mollekopf2016-05-23
|
* Support for folder hierarchiesChristian Mollekopf2016-05-22
|
* ImapResource prototypeChristian Mollekopf2016-05-22