summaryrefslogtreecommitdiffstats
path: root/common/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Mollekopf <chrigi_1@fastmail.fm>2016-03-15 15:16:19 +0100
committerChristian Mollekopf <chrigi_1@fastmail.fm>2016-03-15 15:19:41 +0100
commitb576f6b17e17083257763d5bcb6bf2b64dd200c3 (patch)
treeb83e1e98b0b40e1f75c4a35736486e6e73b6e46d /common/CMakeLists.txt
parent5dab398f76b2d2c6dfdce9ee068c226c9ab20e5b (diff)
downloadsink-b576f6b17e17083257763d5bcb6bf2b64dd200c3.tar.gz
sink-b576f6b17e17083257763d5bcb6bf2b64dd200c3.zip
A test helper to avoid writing to the data directory.
Diffstat (limited to 'common/CMakeLists.txt')
-rw-r--r--common/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/common/CMakeLists.txt b/common/CMakeLists.txt
index 0d61d90..4cb9e91 100644
--- a/common/CMakeLists.txt
+++ b/common/CMakeLists.txt
@@ -63,6 +63,7 @@ set(command_SRCS
63 domain/event.cpp 63 domain/event.cpp
64 domain/mail.cpp 64 domain/mail.cpp
65 domain/folder.cpp 65 domain/folder.cpp
66 test.cpp
66 ${storage_SRCS}) 67 ${storage_SRCS})
67 68
68add_library(${PROJECT_NAME} SHARED ${command_SRCS}) 69add_library(${PROJECT_NAME} SHARED ${command_SRCS})
@@ -113,6 +114,7 @@ install(FILES
113 inspection.h 114 inspection.h
114 notification.h 115 notification.h
115 bufferadaptor.h 116 bufferadaptor.h
117 test.h
116 ${CMAKE_CURRENT_BINARY_DIR}/sink_export.h 118 ${CMAKE_CURRENT_BINARY_DIR}/sink_export.h
117 DESTINATION ${INCLUDE_INSTALL_DIR}/${PROJECT_NAME} COMPONENT Devel 119 DESTINATION ${INCLUDE_INSTALL_DIR}/${PROJECT_NAME} COMPONENT Devel
118) 120)