summaryrefslogtreecommitdiffstats
path: root/common/CMakeLists.txt
diff options
context:
space:
mode:
authorAaron Seigo <aseigo@kde.org>2014-12-05 10:05:19 +0100
committerAaron Seigo <aseigo@kde.org>2014-12-05 10:05:19 +0100
commit93d1c82ffd17df45a5cecd875a01ee3cb15d9983 (patch)
treecda5c31857362ce81f3a50959024f4270d149a07 /common/CMakeLists.txt
parent639fc60c100204c87b93112516cf3b3117cfff0d (diff)
parent351a66b5fb1c8659bff8ea20d60f5a6d2d3263ad (diff)
downloadsink-93d1c82ffd17df45a5cecd875a01ee3cb15d9983.tar.gz
sink-93d1c82ffd17df45a5cecd875a01ee3cb15d9983.zip
Merge branch 'kyoto'
Conflicts: common/storage.h common/storage_lmdb.cpp dummyresource/facade.cpp store/test/CMakeLists.txt tests/storagebenchmark.cpp
Diffstat (limited to 'common/CMakeLists.txt')
-rw-r--r--common/CMakeLists.txt12
1 files changed, 11 insertions, 1 deletions
diff --git a/common/CMakeLists.txt b/common/CMakeLists.txt
index d409828..9b3f777 100644
--- a/common/CMakeLists.txt
+++ b/common/CMakeLists.txt
@@ -2,10 +2,20 @@ project(akonadinextcommon)
2generate_flatbuffers(commands/handshake 2generate_flatbuffers(commands/handshake
3 commands/revisionupdate) 3 commands/revisionupdate)
4 4
5if (STORAGE_KYOTO)
6 set(storage_SRCS storage_kyoto.cpp)
7 set(storage_LIBS kyotocabinet)
8else (STORAGE_KYOTO)
9 set(storage_SRCS storage_lmdb.cpp)
10 set(storage_LIBS lmdb)
11endif (STORAGE_KYOTO)
12
5set(command_SRCS 13set(command_SRCS
6 commands.cpp 14 commands.cpp
7 console.cpp 15 console.cpp
8 ${CMAKE_CURRENT_BINARY_DIR}/commands/handshake_generated.h) 16 ${storage_SRCS})
9 17
10add_library(${PROJECT_NAME} ${command_SRCS}) 18add_library(${PROJECT_NAME} ${command_SRCS})
19SET_TARGET_PROPERTIES(${PROJECT_NAME} PROPERTIES LINKER_LANGUAGE CXX)
11qt5_use_modules(${PROJECT_NAME} Widgets) 20qt5_use_modules(${PROJECT_NAME} Widgets)
21target_link_libraries(${PROJECT_NAME} ${storage_LIBS})