summaryrefslogtreecommitdiffstats
path: root/common/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Mollekopf <chrigi_1@fastmail.fm>2016-01-31 14:00:05 +0100
committerChristian Mollekopf <chrigi_1@fastmail.fm>2016-01-31 14:05:11 +0100
commit7c94e01d9feff8e6c09c88a9e51c8d5a6cb61005 (patch)
treed2a7635629bdb897aaeba592a6c98dcae3450937 /common/CMakeLists.txt
parent380649c1eb762f5f7a10cd15d1c5e87f36b0638c (diff)
downloadsink-7c94e01d9feff8e6c09c88a9e51c8d5a6cb61005.tar.gz
sink-7c94e01d9feff8e6c09c88a9e51c8d5a6cb61005.zip
Explicitly state visibility
This cuts the exportet symbols from 12k to 2k and the library size from 16Mb to 14Mb, which isn't great but still an improvement. About 30% of the symbols are coming from the Store:: interface. nm -C -D /work/install/lib64/libsinkcommon.so.0.1
Diffstat (limited to 'common/CMakeLists.txt')
-rw-r--r--common/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/common/CMakeLists.txt b/common/CMakeLists.txt
index cb7bb35..b400993 100644
--- a/common/CMakeLists.txt
+++ b/common/CMakeLists.txt
@@ -25,6 +25,8 @@ install(FILES
25 COMPONENT Devel 25 COMPONENT Devel
26) 26)
27 27
28add_definitions("-fvisibility=hidden")
29
28install(EXPORT SinkCommonTargets DESTINATION "${CMAKECONFIG_INSTALL_DIR}" FILE SinkCommonTargets.cmake) 30install(EXPORT SinkCommonTargets DESTINATION "${CMAKECONFIG_INSTALL_DIR}" FILE SinkCommonTargets.cmake)
29 31
30set(storage_SRCS storage_lmdb.cpp) 32set(storage_SRCS storage_lmdb.cpp)