summaryrefslogtreecommitdiffstats
path: root/common/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Mollekopf <chrigi_1@fastmail.fm>2016-11-21 23:13:38 +0100
committerChristian Mollekopf <chrigi_1@fastmail.fm>2016-11-21 23:51:24 +0100
commit1d713d9e2dbaf27de9da087f9270d260dfc40c31 (patch)
tree666d8edd42e44df3eaa674a35b6e938b99c2f4b4 /common/CMakeLists.txt
parent0adba61a00491b96dadaa6d4719cb46831356222 (diff)
downloadsink-1d713d9e2dbaf27de9da087f9270d260dfc40c31.tar.gz
sink-1d713d9e2dbaf27de9da087f9270d260dfc40c31.zip
Folded the SourceWriteback into the Synchronizer.
By concentrating all communication to the source in one place we get rid of several oddities. * Quite a bit of duplication since both need access to the synchronizationStore and the source. * We currently have an akward locking in place because both classes access the ync store. This is not easier to resolve cleanly. * The live of resource implementers becomes easier. * An implementation could elect to not use changereplay and always do a full sync... (maybe?)
Diffstat (limited to 'common/CMakeLists.txt')
-rw-r--r--common/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/common/CMakeLists.txt b/common/CMakeLists.txt
index a08be8a..5ba524b 100644
--- a/common/CMakeLists.txt
+++ b/common/CMakeLists.txt
@@ -70,7 +70,6 @@ set(command_SRCS
70 adaptorfactoryregistry.cpp 70 adaptorfactoryregistry.cpp
71 synchronizer.cpp 71 synchronizer.cpp
72 remoteidmap.cpp 72 remoteidmap.cpp
73 sourcewriteback.cpp
74 mailpreprocessor.cpp 73 mailpreprocessor.cpp
75 specialpurposepreprocessor.cpp 74 specialpurposepreprocessor.cpp
76 datastorequery.cpp 75 datastorequery.cpp