summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Mollekopf <chrigi_1@fastmail.fm>2017-11-07 15:27:42 +0100
committerChristian Mollekopf <chrigi_1@fastmail.fm>2017-11-07 15:27:42 +0100
commitc6119654921decf0412149484b546dfc4902346c (patch)
tree5a4d8c3f0e37ebb9593258a0e01277a3fcbfaace /CMakeLists.txt
parentff3a97de55176ae600124695ae9aa815b5ff2f18 (diff)
downloadsink-c6119654921decf0412149484b546dfc4902346c.tar.gz
sink-c6119654921decf0412149484b546dfc4902346c.zip
Require valgrind when enabling memcheck
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cef0c3c..5ee08ae 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -36,8 +36,13 @@ find_package(FlatBuffers REQUIRED 1.4.0)
36find_package(KAsync REQUIRED 0.1.2) 36find_package(KAsync REQUIRED 0.1.2)
37find_package(LMDB REQUIRED 0.9) 37find_package(LMDB REQUIRED 0.9)
38 38
39find_program(MEMORYCHECK_COMMAND valgrind) 39if (${ENABLE_MEMCHECK})
40set(MEMORYCHECK_COMMAND_OPTIONS "--trace-children=yes --leak-check=full") 40 find_program(MEMORYCHECK_COMMAND valgrind)
41 if(NOT MEMORYCHECK_COMMAND)
42 message(FATAL_ERROR "valgrind not found!")
43 endif()
44 set(MEMORYCHECK_COMMAND_OPTIONS "--trace-children=yes --leak-check=full")
45endif()
41 46
42#Clang-format support 47#Clang-format support
43add_custom_command( 48add_custom_command(