summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDan Vrátil <dvratil@redhat.com>2015-05-18 15:20:45 +0200
committerDan Vrátil <dvratil@redhat.com>2015-05-18 15:20:45 +0200
commita882d614ab4500955adb4aa184776c33a06d6a40 (patch)
treec06e4f9d389bd8c01a6345587dd7f0c89f1e5d33 /CMakeLists.txt
parent5e580299e342bd77fc7479bbfd235f4446d7f05b (diff)
downloadsink-a882d614ab4500955adb4aa184776c33a06d6a40.tar.gz
sink-a882d614ab4500955adb4aa184776c33a06d6a40.zip
Fix flatbuffers generator for tests
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 45a6ef5..bd4a229 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -31,8 +31,8 @@ function(generate_flatbuffers _target)
31 ) 31 )
32 set_source_files_properties(${CMAKE_CURRENT_BINARY_DIR}/${fbs}_generated.h PROPERTIES GENERATED 1) 32 set_source_files_properties(${CMAKE_CURRENT_BINARY_DIR}/${fbs}_generated.h PROPERTIES GENERATED 1)
33 string(REGEX REPLACE "/" "_" target_name ${fbs}) 33 string(REGEX REPLACE "/" "_" target_name ${fbs})
34 add_custom_target(generate_bindings${target_name} ALL DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/${fbs}_generated.h) 34 add_custom_target(${_target}-generate_bindings${target_name} ALL DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/${fbs}_generated.h)
35 add_dependencies(${_target} generate_bindings${target_name}) 35 add_dependencies(${_target} ${_target}-generate_bindings${target_name})
36 endforeach(fbs) 36 endforeach(fbs)
37endfunction(generate_flatbuffers) 37endfunction(generate_flatbuffers)
38 38