summaryrefslogtreecommitdiffstats
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix6
1 files changed, 1 insertions, 5 deletions
diff --git a/default.nix b/default.nix
index 302f008..8ba6c08 100644
--- a/default.nix
+++ b/default.nix
@@ -31,14 +31,10 @@
31 31
32 kubeSrc, 32 kubeSrc,
33 33
34 compiler ? "gcc7",
35 cmakeBuildType ? "Debug" 34 cmakeBuildType ? "Debug"
36}: 35}:
37 36
38let 37rec {
39 stdenv = nixpkgs.overrideCC nixpkgs.stdenv nixpkgs.${compiler};
40
41in rec {
42 kasync = stdenv.mkDerivation { 38 kasync = stdenv.mkDerivation {
43 name = "kasync"; 39 name = "kasync";
44 nativeBuildInputs = with nixpkgs; [ cmake ninja ccache ]; 40 nativeBuildInputs = with nixpkgs; [ cmake ninja ccache ];