diff options
author | Minijackson <minijackson@riseup.net> | 2018-08-09 14:15:41 +0200 |
---|---|---|
committer | Minijackson <minijackson@riseup.net> | 2018-08-09 14:15:41 +0200 |
commit | 6adb43248df6feccb414fefa4b9a36c7a7acbf31 (patch) | |
tree | e6e631093f1e5ff1ecb05c2e48ff52b5d21918b4 /default.nix | |
parent | e9bb45821f28a804daa39f7defbfc8b69c7fe0b4 (diff) | |
download | nix_repo-6adb43248df6feccb414fefa4b9a36c7a7acbf31.tar.gz nix_repo-6adb43248df6feccb414fefa4b9a36c7a7acbf31.zip |
pkgs => nixpkgs
Diffstat (limited to 'default.nix')
-rw-r--r-- | default.nix | 31 |
1 files changed, 15 insertions, 16 deletions
diff --git a/default.nix b/default.nix index 3f74b23..5e0b2a4 100644 --- a/default.nix +++ b/default.nix | |||
@@ -1,28 +1,28 @@ | |||
1 | { | 1 | { |
2 | nixpkgs ? import <nixpkgs> {}, | 2 | nixpkgs ? import <nixpkgs> {}, |
3 | 3 | ||
4 | kasyncSrc ? pkgs.fetchgit { | 4 | kasyncSrc ? nixpkgs.fetchgit { |
5 | url = "https://anongit.kde.org/kasync.git"; | 5 | url = "https://anongit.kde.org/kasync.git"; |
6 | rev = "8a68ad7da7f9d7d10d249a16a474fa7ca82517be"; | 6 | rev = "8a68ad7da7f9d7d10d249a16a474fa7ca82517be"; |
7 | sha256 = "1v55my24d3zhllw77sjzngs6cwddjqf9xw9v0hkwk2gq2znwp6g8"; | 7 | sha256 = "1v55my24d3zhllw77sjzngs6cwddjqf9xw9v0hkwk2gq2znwp6g8"; |
8 | fetchSubmodules = true; | 8 | fetchSubmodules = true; |
9 | }, | 9 | }, |
10 | 10 | ||
11 | kimap2Src ? pkgs.fetchgit { | 11 | kimap2Src ? nixpkgs.fetchgit { |
12 | url = "https://anongit.kde.org/kimap2.git"; | 12 | url = "https://anongit.kde.org/kimap2.git"; |
13 | rev = "62df1b858b3fd7c6c4b3229ff5051c0e4996b1be"; | 13 | rev = "62df1b858b3fd7c6c4b3229ff5051c0e4996b1be"; |
14 | sha256 = "1q43dzza1v5kjsvzisw5j2750550596s6hra45xbqny08hkpk355"; | 14 | sha256 = "1q43dzza1v5kjsvzisw5j2750550596s6hra45xbqny08hkpk355"; |
15 | fetchSubmodules = true; | 15 | fetchSubmodules = true; |
16 | }, | 16 | }, |
17 | 17 | ||
18 | kdav2Src ? pkgs.fetchgit { | 18 | kdav2Src ? nixpkgs.fetchgit { |
19 | url = "https://anongit.kde.org/kdav2.git"; | 19 | url = "https://anongit.kde.org/kdav2.git"; |
20 | rev = "830f07b99dc8badf5df40edb81cbac63a3ddb3c4"; | 20 | rev = "830f07b99dc8badf5df40edb81cbac63a3ddb3c4"; |
21 | sha256 = "1da6ivjjq9bh855jiv0kzxi83z736iazn747gkaj261ai8qn7spz"; | 21 | sha256 = "1da6ivjjq9bh855jiv0kzxi83z736iazn747gkaj261ai8qn7spz"; |
22 | fetchSubmodules = true; | 22 | fetchSubmodules = true; |
23 | }, | 23 | }, |
24 | 24 | ||
25 | sinkSrc ? pkgs.fetchgit { | 25 | sinkSrc ? nixpkgs.fetchgit { |
26 | url = "https://github.com/KDE/sink"; | 26 | url = "https://github.com/KDE/sink"; |
27 | rev = "e1a6d6f5bbaeeffd92a2049849b75e248c2d492b"; | 27 | rev = "e1a6d6f5bbaeeffd92a2049849b75e248c2d492b"; |
28 | sha256 = "196vqd7gk93mfizxnfz918rs5g3723ndarx79x84q8qvk7bngc0v"; | 28 | sha256 = "196vqd7gk93mfizxnfz918rs5g3723ndarx79x84q8qvk7bngc0v"; |
@@ -35,13 +35,12 @@ | |||
35 | 35 | ||
36 | let | 36 | let |
37 | stdenv = nixpkgs.overrideCC nixpkgs.stdenv nixpkgs.${compiler}; | 37 | stdenv = nixpkgs.overrideCC nixpkgs.stdenv nixpkgs.${compiler}; |
38 | pkgs = nixpkgs; | ||
39 | 38 | ||
40 | in rec { | 39 | in rec { |
41 | kasync = stdenv.mkDerivation { | 40 | kasync = stdenv.mkDerivation { |
42 | name = "kasync"; | 41 | name = "kasync"; |
43 | nativeBuildInputs = with pkgs; [ cmake ninja ccache ]; | 42 | nativeBuildInputs = with nixpkgs; [ cmake ninja ccache ]; |
44 | buildInputs = with pkgs; with qt5; | 43 | buildInputs = with nixpkgs; with qt5; |
45 | [ extra-cmake-modules qtbase ]; | 44 | [ extra-cmake-modules qtbase ]; |
46 | 45 | ||
47 | src = kasyncSrc; | 46 | src = kasyncSrc; |
@@ -51,8 +50,8 @@ in rec { | |||
51 | 50 | ||
52 | kimap2 = stdenv.mkDerivation { | 51 | kimap2 = stdenv.mkDerivation { |
53 | name = "kimap2"; | 52 | name = "kimap2"; |
54 | nativeBuildInputs = with pkgs; [ cmake ninja ccache ]; | 53 | nativeBuildInputs = with nixpkgs; [ cmake ninja ccache ]; |
55 | buildInputs = with pkgs; with qt5; with kdeFrameworks; | 54 | buildInputs = with nixpkgs; with qt5; with kdeFrameworks; |
56 | [ extra-cmake-modules qtbase kcoreaddons kcodecs kdeApplications.kmime cyrus_sasl ]; | 55 | [ extra-cmake-modules qtbase kcoreaddons kcodecs kdeApplications.kmime cyrus_sasl ]; |
57 | 56 | ||
58 | src = kimap2Src; | 57 | src = kimap2Src; |
@@ -61,8 +60,8 @@ in rec { | |||
61 | 60 | ||
62 | kdav2 = stdenv.mkDerivation { | 61 | kdav2 = stdenv.mkDerivation { |
63 | name = "kdav2"; | 62 | name = "kdav2"; |
64 | nativeBuildInputs = with pkgs; [ cmake ninja ccache ]; | 63 | nativeBuildInputs = with nixpkgs; [ cmake ninja ccache ]; |
65 | buildInputs = with pkgs; with qt5; with kdeFrameworks; | 64 | buildInputs = with nixpkgs; with qt5; with kdeFrameworks; |
66 | [ extra-cmake-modules qtbase qtxmlpatterns kcoreaddons ]; | 65 | [ extra-cmake-modules qtbase qtxmlpatterns kcoreaddons ]; |
67 | 66 | ||
68 | src = kdav2Src; | 67 | src = kdav2Src; |
@@ -72,8 +71,8 @@ in rec { | |||
72 | 71 | ||
73 | sink = stdenv.mkDerivation { | 72 | sink = stdenv.mkDerivation { |
74 | name = "sink"; | 73 | name = "sink"; |
75 | nativeBuildInputs = with pkgs; [ cmake ninja ccache ]; | 74 | nativeBuildInputs = with nixpkgs; [ cmake ninja ccache ]; |
76 | buildInputs = with pkgs; with qt5; with kdeApplications; | 75 | buildInputs = with nixpkgs; with qt5; with kdeApplications; |
77 | [ | 76 | [ |
78 | extra-cmake-modules kmime kcontacts kcalcore | 77 | extra-cmake-modules kmime kcontacts kcalcore |
79 | flatbuffers lmdb xapian cyrus_sasl curl libgit2 readline | 78 | flatbuffers lmdb xapian cyrus_sasl curl libgit2 readline |
@@ -94,8 +93,8 @@ in rec { | |||
94 | 93 | ||
95 | kube = stdenv.mkDerivation { | 94 | kube = stdenv.mkDerivation { |
96 | name = "kube"; | 95 | name = "kube"; |
97 | nativeBuildInputs = with pkgs; [ cmake ninja ccache ]; | 96 | nativeBuildInputs = with nixpkgs; [ cmake ninja ccache ]; |
98 | buildInputs = with pkgs; with qt5; with kdeFrameworks; with kdeApplications; with libsForQt5; | 97 | buildInputs = with nixpkgs; with qt5; with kdeFrameworks; with kdeApplications; with libsForQt5; |
99 | [ | 98 | [ |
100 | extra-cmake-modules kcalcore kcodecs kcontacts kmime | 99 | extra-cmake-modules kcalcore kcodecs kcontacts kmime |
101 | qtbase qtquickcontrols2 qtwebengine qgpgme | 100 | qtbase qtquickcontrols2 qtwebengine qgpgme |
@@ -108,7 +107,7 @@ in rec { | |||
108 | CCACHE_UMASK = "007"; | 107 | CCACHE_UMASK = "007"; |
109 | 108 | ||
110 | cmakeFlags = [ | 109 | cmakeFlags = [ |
111 | #"-DCMAKE_CXX_COMPILER_LAUNCHER=${pkgs.ccache}/bin/ccache" | 110 | #"-DCMAKE_CXX_COMPILER_LAUNCHER=${nixpkgs.ccache}/bin/ccache" |
112 | "-DCMAKE_CXX_FLAGS=-fdiagnostics-color=always" | 111 | "-DCMAKE_CXX_FLAGS=-fdiagnostics-color=always" |
113 | "-DCMAKE_EXPORT_COMPILE_COMMANDS=1" | 112 | "-DCMAKE_EXPORT_COMPILE_COMMANDS=1" |
114 | ]; | 113 | ]; |