diff options
Diffstat (limited to 'accounts/kolabnow/CMakeLists.txt')
-rw-r--r-- | accounts/kolabnow/CMakeLists.txt | 18 |
1 files changed, 14 insertions, 4 deletions
diff --git a/accounts/kolabnow/CMakeLists.txt b/accounts/kolabnow/CMakeLists.txt index 7b181522..8a178bf9 100644 --- a/accounts/kolabnow/CMakeLists.txt +++ b/accounts/kolabnow/CMakeLists.txt | |||
@@ -33,12 +33,22 @@ set(SRCS | |||
33 | ) | 33 | ) |
34 | 34 | ||
35 | add_library(kolabnowaccountplugin SHARED ${SRCS}) | 35 | add_library(kolabnowaccountplugin SHARED ${SRCS}) |
36 | qt5_use_modules(kolabnowaccountplugin Core Quick Qml) | 36 | target_link_libraries(kolabnowaccountplugin |
37 | target_link_libraries(kolabnowaccountplugin sink frameworkplugin) | 37 | sink |
38 | frameworkplugin | ||
39 | Qt5::Core | ||
40 | Qt5::Quick | ||
41 | Qt5::Qml | ||
42 | ) | ||
38 | 43 | ||
39 | add_library(kolabnowaccount_static STATIC ${SRCS}) | 44 | add_library(kolabnowaccount_static STATIC ${SRCS}) |
40 | qt5_use_modules(kolabnowaccount_static Core Quick Qml) | 45 | target_link_libraries(kolabnowaccount_static |
41 | target_link_libraries(kolabnowaccount_static sink frameworkplugin) | 46 | sink |
47 | frameworkplugin | ||
48 | Qt5::Core | ||
49 | Qt5::Quick | ||
50 | Qt5::Qml | ||
51 | ) | ||
42 | # add_subdirectory(tests) | 52 | # add_subdirectory(tests) |
43 | 53 | ||
44 | kpackage_install_package(package org.kube.accounts.kolabnow "genericqml") | 54 | kpackage_install_package(package org.kube.accounts.kolabnow "genericqml") |