diff options
author | Heiko Becker <heirecka@exherbo.org> | 2017-06-02 21:35:37 +0200 |
---|---|---|
committer | Heiko Becker <heirecka@exherbo.org> | 2017-07-29 11:01:28 +0200 |
commit | 51fbcca97ef9058cdb75c52ac77bdc728a296e4a (patch) | |
tree | 982206bd7c35353a10839802d237e53692fe7116 /accounts/kolabnow/CMakeLists.txt | |
parent | ba32e5a606c77b968f53239caf276456c81b4db7 (diff) | |
download | kube-51fbcca97ef9058cdb75c52ac77bdc728a296e4a.tar.gz kube-51fbcca97ef9058cdb75c52ac77bdc728a296e4a.zip |
Use imported targets instead of qt5_use_modules
From Qt's documentation: "This macro is obsolete. Use
target_link_libraries with IMPORTED targets instead." It's only
recommended with cmake >=2.8.9 & < 2.8.12. Kube already requires
cmake 3.0.
One advantage of using the imported targets is, that
cmake complains if a target isn't found before it's used, like
Qt5Concurrent missing from the find_package_call here.
Reviewers: #kube, cmollekopf
Reviewed By: #kube, cmollekopf
Subscribers: #kube
Differential Revision: https://phabricator.kde.org/D6362
Diffstat (limited to 'accounts/kolabnow/CMakeLists.txt')
-rw-r--r-- | accounts/kolabnow/CMakeLists.txt | 18 |
1 files changed, 14 insertions, 4 deletions
diff --git a/accounts/kolabnow/CMakeLists.txt b/accounts/kolabnow/CMakeLists.txt index 7b181522..8a178bf9 100644 --- a/accounts/kolabnow/CMakeLists.txt +++ b/accounts/kolabnow/CMakeLists.txt | |||
@@ -33,12 +33,22 @@ set(SRCS | |||
33 | ) | 33 | ) |
34 | 34 | ||
35 | add_library(kolabnowaccountplugin SHARED ${SRCS}) | 35 | add_library(kolabnowaccountplugin SHARED ${SRCS}) |
36 | qt5_use_modules(kolabnowaccountplugin Core Quick Qml) | 36 | target_link_libraries(kolabnowaccountplugin |
37 | target_link_libraries(kolabnowaccountplugin sink frameworkplugin) | 37 | sink |
38 | frameworkplugin | ||
39 | Qt5::Core | ||
40 | Qt5::Quick | ||
41 | Qt5::Qml | ||
42 | ) | ||
38 | 43 | ||
39 | add_library(kolabnowaccount_static STATIC ${SRCS}) | 44 | add_library(kolabnowaccount_static STATIC ${SRCS}) |
40 | qt5_use_modules(kolabnowaccount_static Core Quick Qml) | 45 | target_link_libraries(kolabnowaccount_static |
41 | target_link_libraries(kolabnowaccount_static sink frameworkplugin) | 46 | sink |
47 | frameworkplugin | ||
48 | Qt5::Core | ||
49 | Qt5::Quick | ||
50 | Qt5::Qml | ||
51 | ) | ||
42 | # add_subdirectory(tests) | 52 | # add_subdirectory(tests) |
43 | 53 | ||
44 | kpackage_install_package(package org.kube.accounts.kolabnow "genericqml") | 54 | kpackage_install_package(package org.kube.accounts.kolabnow "genericqml") |