summaryrefslogtreecommitdiffstats
path: root/framework/src/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Mollekopf <chrigi_1@fastmail.fm>2017-08-20 13:55:56 -0600
committerChristian Mollekopf <chrigi_1@fastmail.fm>2017-08-20 13:55:56 -0600
commitf6e6cd8a5c8ef2d8d7e331834dff026646be543e (patch)
tree68fda89590301378d1e2658498451a1c43f55aea /framework/src/CMakeLists.txt
parentc6d028cebbfce9e4d9437ace37a5ac327eaee25d (diff)
downloadkube-f6e6cd8a5c8ef2d8d7e331834dff026646be543e.tar.gz
kube-f6e6cd8a5c8ef2d8d7e331834dff026646be543e.zip
Filter enabled folders using a krecursivefilterproxymodel
The KRecursiveFilterProxyModel is necessary until Qt 5.10 when QSortFilterProxyModel will support recursive filtering. For the recursive filtering to work we need to make all data available, so we trigger fetchMore on all added indexes.
Diffstat (limited to 'framework/src/CMakeLists.txt')
-rw-r--r--framework/src/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/framework/src/CMakeLists.txt b/framework/src/CMakeLists.txt
index 9c845022..86145d5a 100644
--- a/framework/src/CMakeLists.txt
+++ b/framework/src/CMakeLists.txt
@@ -42,6 +42,7 @@ set(SRCS
42 sinkfabric.cpp 42 sinkfabric.cpp
43 kubeimage.cpp 43 kubeimage.cpp
44 clipboardproxy.cpp 44 clipboardproxy.cpp
45 krecursivefilterproxymodel.cpp
45) 46)
46 47
47add_library(frameworkplugin SHARED ${SRCS}) 48add_library(frameworkplugin SHARED ${SRCS})