diff options
author | Christian Mollekopf <chrigi_1@fastmail.fm> | 2017-08-22 20:19:53 -0600 |
---|---|---|
committer | Christian Mollekopf <chrigi_1@fastmail.fm> | 2017-08-22 20:19:53 -0600 |
commit | dfa1c2dab99115a1ad97f4e2e93ac07e2d0705fd (patch) | |
tree | df28c8dc60e9718e12093425497268b5021a0a1d /framework/src/CMakeLists.txt | |
parent | 2844ef37db4c498f39ba9804483831a27b8aa412 (diff) | |
download | kube-dfa1c2dab99115a1ad97f4e2e93ac07e2d0705fd.tar.gz kube-dfa1c2dab99115a1ad97f4e2e93ac07e2d0705fd.zip |
Install the webengineprofile as singleton
This fixes the bug that the main process would hang on exit as long as
we have a requestinterceptor installed. It's most likely a bug that this
does not work, but the new solution anyways cleans up the code a bit, so
that's a nice sideeffect.
Fixes T5570
Diffstat (limited to 'framework/src/CMakeLists.txt')
-rw-r--r-- | framework/src/CMakeLists.txt | 4 |
1 files changed, 3 insertions, 1 deletions
diff --git a/framework/src/CMakeLists.txt b/framework/src/CMakeLists.txt index 86145d5a..1ac9d3c2 100644 --- a/framework/src/CMakeLists.txt +++ b/framework/src/CMakeLists.txt | |||
@@ -1,5 +1,5 @@ | |||
1 | 1 | ||
2 | find_package(Qt5 COMPONENTS REQUIRED Core Concurrent Quick Qml WebEngineWidgets Test) | 2 | find_package(Qt5 COMPONENTS REQUIRED Core Concurrent Quick Qml WebEngineWidgets Test WebEngine) |
3 | find_package(KF5Mime "4.87.0" CONFIG REQUIRED) | 3 | find_package(KF5Mime "4.87.0" CONFIG REQUIRED) |
4 | find_package(Sink CONFIG REQUIRED) | 4 | find_package(Sink CONFIG REQUIRED) |
5 | find_package(KAsync CONFIG REQUIRED) | 5 | find_package(KAsync CONFIG REQUIRED) |
@@ -43,6 +43,7 @@ set(SRCS | |||
43 | kubeimage.cpp | 43 | kubeimage.cpp |
44 | clipboardproxy.cpp | 44 | clipboardproxy.cpp |
45 | krecursivefilterproxymodel.cpp | 45 | krecursivefilterproxymodel.cpp |
46 | webengineprofile.cpp | ||
46 | ) | 47 | ) |
47 | 48 | ||
48 | add_library(frameworkplugin SHARED ${SRCS}) | 49 | add_library(frameworkplugin SHARED ${SRCS}) |
@@ -54,6 +55,7 @@ target_link_libraries(frameworkplugin | |||
54 | Qt5::Qml | 55 | Qt5::Qml |
55 | Qt5::WebEngineWidgets | 56 | Qt5::WebEngineWidgets |
56 | Qt5::Test | 57 | Qt5::Test |
58 | Qt5::WebEngine | ||
57 | KF5::Codecs | 59 | KF5::Codecs |
58 | KF5::Contacts | 60 | KF5::Contacts |
59 | KF5::Package | 61 | KF5::Package |