diff options
author | Christian Mollekopf <chrigi_1@fastmail.fm> | 2016-03-01 00:08:45 +0100 |
---|---|---|
committer | Christian Mollekopf <chrigi_1@fastmail.fm> | 2016-03-01 00:08:45 +0100 |
commit | 235b8cb38214fe1ec919fce8701737d7b944c6de (patch) | |
tree | 92468fe9c9f939086d8dac6f01d36f4f71a40c95 /framework/mail/CMakeLists.txt | |
parent | 0467b39e1ca034ec7298017e3055e352c755a386 (diff) | |
download | kube-235b8cb38214fe1ec919fce8701737d7b944c6de.tar.gz kube-235b8cb38214fe1ec919fce8701737d7b944c6de.zip |
Support for mail replies
A template message is generated based on the input message,
including appropriate recepients and quoted text.
Encoding and and options are mostly hardcoded still,
and there might be one or the other crash with HTML mails.
Also image/attachment support is incomplete.
Diffstat (limited to 'framework/mail/CMakeLists.txt')
-rw-r--r-- | framework/mail/CMakeLists.txt | 3 |
1 files changed, 2 insertions, 1 deletions
diff --git a/framework/mail/CMakeLists.txt b/framework/mail/CMakeLists.txt index 29fda0e4..822b2981 100644 --- a/framework/mail/CMakeLists.txt +++ b/framework/mail/CMakeLists.txt | |||
@@ -13,6 +13,7 @@ set(mailplugin_SRCS | |||
13 | composer.cpp | 13 | composer.cpp |
14 | messageparser.cpp | 14 | messageparser.cpp |
15 | mailtransport.cpp | 15 | mailtransport.cpp |
16 | mailtemplates.cpp | ||
16 | retriever.cpp | 17 | retriever.cpp |
17 | ) | 18 | ) |
18 | add_definitions(-DMAIL_DATA_DIR="${CMAKE_CURRENT_SOURCE_DIR}/data") | 19 | add_definitions(-DMAIL_DATA_DIR="${CMAKE_CURRENT_SOURCE_DIR}/data") |
@@ -23,7 +24,7 @@ include_directories(${CURL_INCLUDE_DIRS}) | |||
23 | 24 | ||
24 | add_library(mailplugin SHARED ${mailplugin_SRCS}) | 25 | add_library(mailplugin SHARED ${mailplugin_SRCS}) |
25 | 26 | ||
26 | qt5_use_modules(mailplugin Core Quick Qml) | 27 | qt5_use_modules(mailplugin Core Quick Qml WebKitWidgets) |
27 | 28 | ||
28 | target_link_libraries(mailplugin actionplugin settingsplugin sink KF5::Otp KF5::Codecs ${CURL_LIBRARIES}) | 29 | target_link_libraries(mailplugin actionplugin settingsplugin sink KF5::Otp KF5::Codecs ${CURL_LIBRARIES}) |
29 | 30 | ||