summaryrefslogtreecommitdiffstats
path: root/components/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Mollekopf <chrigi_1@fastmail.fm>2017-08-23 18:39:44 -0600
committerChristian Mollekopf <chrigi_1@fastmail.fm>2017-08-23 18:39:44 -0600
commit85dc437da27417cce05b5a9f97505b43cfdf4dee (patch)
tree3b6984e9f42a085fae821d4024326987a48fdc98 /components/CMakeLists.txt
parent25b4f6e2d7ed2d783b8ee1eefbe62df713ca0341 (diff)
downloadkube-85dc437da27417cce05b5a9f97505b43cfdf4dee.tar.gz
kube-85dc437da27417cce05b5a9f97505b43cfdf4dee.zip
The grand cmake cleanup
We had a ton of duplication in our cmake code because we had no common toplevel settings. This is now cleaned up so we can sanely change settings and so we know what we have set.
Diffstat (limited to 'components/CMakeLists.txt')
-rw-r--r--components/CMakeLists.txt18
1 files changed, 0 insertions, 18 deletions
diff --git a/components/CMakeLists.txt b/components/CMakeLists.txt
index 8b988fab..7b06929f 100644
--- a/components/CMakeLists.txt
+++ b/components/CMakeLists.txt
@@ -1,26 +1,8 @@
1project(kube-components) 1project(kube-components)
2 2
3cmake_minimum_required(VERSION 2.8.12)
4
5include(CPack)
6include(FeatureSummary)
7find_package(PkgConfig)
8
9################# set KDE specific information #################
10
11find_package(ECM 0.0.8 REQUIRED NO_MODULE)
12
13# where to look first for cmake modules, before ${CMAKE_ROOT}/Modules/ is checked
14set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${ECM_MODULE_PATH} ${ECM_KDE_MODULE_DIR})
15
16include(KDEInstallDirs)
17include(KDECMakeSettings)
18include(KDECompilerSettings)
19
20find_package(Qt5 REQUIRED NO_MODULE COMPONENTS Core Quick Test Gui Widgets) 3find_package(Qt5 REQUIRED NO_MODULE COMPONENTS Core Quick Test Gui Widgets)
21find_package(KF5 REQUIRED COMPONENTS Package) 4find_package(KF5 REQUIRED COMPONENTS Package)
22 5
23
24macro(install_component name) 6macro(install_component name)
25 install(DIRECTORY ${name}/contents/ui/ DESTINATION ${QML_INSTALL_DIR}/org/kube/components/${name}) 7 install(DIRECTORY ${name}/contents/ui/ DESTINATION ${QML_INSTALL_DIR}/org/kube/components/${name})
26 install(FILES ${name}/qmldir DESTINATION ${QML_INSTALL_DIR}/org/kube/components/${name}) 8 install(FILES ${name}/qmldir DESTINATION ${QML_INSTALL_DIR}/org/kube/components/${name})