summaryrefslogtreecommitdiffstats
path: root/accounts/maildir/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Mollekopf <chrigi_1@fastmail.fm>2016-03-15 09:17:48 +0100
committerChristian Mollekopf <chrigi_1@fastmail.fm>2016-03-15 09:17:48 +0100
commita324759edfd9d3470aa4dc5a6e5e966682cd70c2 (patch)
tree9e560ebde564d62bf374f30aeb4cdd3d8414a7ca /accounts/maildir/CMakeLists.txt
parentbf039428e22a10887e8d85a95ff5f38dc17e7ec2 (diff)
downloadkube-a324759edfd9d3470aa4dc5a6e5e966682cd70c2.tar.gz
kube-a324759edfd9d3470aa4dc5a6e5e966682cd70c2.zip
Prepared a settingstest
Diffstat (limited to 'accounts/maildir/CMakeLists.txt')
-rw-r--r--accounts/maildir/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/accounts/maildir/CMakeLists.txt b/accounts/maildir/CMakeLists.txt
index eafd430f..bc9854d5 100644
--- a/accounts/maildir/CMakeLists.txt
+++ b/accounts/maildir/CMakeLists.txt
@@ -37,6 +37,11 @@ add_library(maildiraccountplugin SHARED ${SRCS})
37qt5_use_modules(maildiraccountplugin Core Quick Qml) 37qt5_use_modules(maildiraccountplugin Core Quick Qml)
38target_link_libraries(maildiraccountplugin sink settingsplugin) 38target_link_libraries(maildiraccountplugin sink settingsplugin)
39 39
40add_library(maildiraccount_static STATIC ${SRCS})
41qt5_use_modules(maildiraccount_static Core Quick Qml)
42target_link_libraries(maildiraccount_static sink settingsplugin)
43add_subdirectory(tests)
44
40kpackage_install_package(package org.kube.accounts.maildir "genericqml") 45kpackage_install_package(package org.kube.accounts.maildir "genericqml")
41 46
42install(TARGETS maildiraccountplugin DESTINATION ${QML_INSTALL_DIR}/org/kube/accounts/maildir) 47install(TARGETS maildiraccountplugin DESTINATION ${QML_INSTALL_DIR}/org/kube/accounts/maildir)