summaryrefslogtreecommitdiffstats
path: root/accounts/maildir/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Mollekopf <chrigi_1@fastmail.fm>2016-03-10 11:57:08 +0100
committerChristian Mollekopf <chrigi_1@fastmail.fm>2016-03-10 11:57:08 +0100
commit9bfadc71a4fb694ae3946711d04acdfe009264c0 (patch)
tree883c944c166e8b31862ba2a898ab6aed1944b0aa /accounts/maildir/CMakeLists.txt
parentd0617d0ad6926c250e29d1a40db93733fa911e5d (diff)
downloadkube-9bfadc71a4fb694ae3946711d04acdfe009264c0.tar.gz
kube-9bfadc71a4fb694ae3946711d04acdfe009264c0.zip
A factory to load account plugins.
Diffstat (limited to 'accounts/maildir/CMakeLists.txt')
-rw-r--r--accounts/maildir/CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/accounts/maildir/CMakeLists.txt b/accounts/maildir/CMakeLists.txt
index d83ae0be..5307c5b0 100644
--- a/accounts/maildir/CMakeLists.txt
+++ b/accounts/maildir/CMakeLists.txt
@@ -22,6 +22,7 @@ find_package(Qt5 REQUIRED NO_MODULE COMPONENTS Core Quick Test Gui)
22set (QT_MIN_VERSION "5.4.0") 22set (QT_MIN_VERSION "5.4.0")
23find_package(Sink CONFIG REQUIRED) 23find_package(Sink CONFIG REQUIRED)
24find_package(KF5Async CONFIG REQUIRED) 24find_package(KF5Async CONFIG REQUIRED)
25find_package(KF5 REQUIRED COMPONENTS Package)
25 26
26include_directories(SYSTEM ${KDE_INSTALL_FULL_INCLUDEDIR}/KF5/) 27include_directories(SYSTEM ${KDE_INSTALL_FULL_INCLUDEDIR}/KF5/)
27 28
@@ -34,7 +35,7 @@ add_library(maildiraccountplugin SHARED ${SRCS})
34qt5_use_modules(maildiraccountplugin Core Quick Qml) 35qt5_use_modules(maildiraccountplugin Core Quick Qml)
35target_link_libraries(maildiraccountplugin sink) 36target_link_libraries(maildiraccountplugin sink)
36 37
37install(TARGETS maildiraccountplugin DESTINATION ${QML_INSTALL_DIR}/org/kde/kube/accounts/maildir) 38kpackage_install_package(package org.kube.accounts.maildir "genericqml")
38install(FILES qmldir DESTINATION ${QML_INSTALL_DIR}/org/kde/kube/accounts/maildir)
39install(FILES package/contents/ui/MaildirAccountSettings.qml DESTINATION ${QML_INSTALL_DIR}/org/kde/kube/accounts/maildir)
40 39
40install(TARGETS maildiraccountplugin DESTINATION ${QML_INSTALL_DIR}/org/kube/accounts/maildir)
41install(FILES qmldir DESTINATION ${QML_INSTALL_DIR}/org/kube/accounts/maildir)