summaryrefslogtreecommitdiffstats
path: root/accounts/imap/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorHeiko Becker <heirecka@exherbo.org>2017-06-02 21:35:37 +0200
committerHeiko Becker <heirecka@exherbo.org>2017-07-29 11:01:28 +0200
commit51fbcca97ef9058cdb75c52ac77bdc728a296e4a (patch)
tree982206bd7c35353a10839802d237e53692fe7116 /accounts/imap/tests/CMakeLists.txt
parentba32e5a606c77b968f53239caf276456c81b4db7 (diff)
downloadkube-51fbcca97ef9058cdb75c52ac77bdc728a296e4a.tar.gz
kube-51fbcca97ef9058cdb75c52ac77bdc728a296e4a.zip
Use imported targets instead of qt5_use_modules
From Qt's documentation: "This macro is obsolete. Use target_link_libraries with IMPORTED targets instead." It's only recommended with cmake >=2.8.9 & < 2.8.12. Kube already requires cmake 3.0. One advantage of using the imported targets is, that cmake complains if a target isn't found before it's used, like Qt5Concurrent missing from the find_package_call here. Reviewers: #kube, cmollekopf Reviewed By: #kube, cmollekopf Subscribers: #kube Differential Revision: https://phabricator.kde.org/D6362
Diffstat (limited to 'accounts/imap/tests/CMakeLists.txt')
-rw-r--r--accounts/imap/tests/CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/accounts/imap/tests/CMakeLists.txt b/accounts/imap/tests/CMakeLists.txt
index 9c914370..82d6059c 100644
--- a/accounts/imap/tests/CMakeLists.txt
+++ b/accounts/imap/tests/CMakeLists.txt
@@ -2,5 +2,10 @@ include_directories(../)
2cmake_policy(SET CMP0063 NEW) 2cmake_policy(SET CMP0063 NEW)
3add_executable(imapsettingstest settingstest.cpp) 3add_executable(imapsettingstest settingstest.cpp)
4add_test(imapsettingstest settingstest) 4add_test(imapsettingstest settingstest)
5qt5_use_modules(imapsettingstest Core Test Concurrent) 5target_link_libraries(imapsettingstest
6target_link_libraries(imapsettingstest sink imapaccount_static) 6 sink
7 imapaccount_static
8 Qt5::Core
9 Qt5::Concurrent
10 Qt5::Test
11)