summaryrefslogtreecommitdiffstats
path: root/derivation.nix
diff options
context:
space:
mode:
Diffstat (limited to 'derivation.nix')
-rw-r--r--derivation.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/derivation.nix b/derivation.nix
new file mode 100644
index 0000000..329ef3b
--- /dev/null
+++ b/derivation.nix
@@ -0,0 +1,17 @@
1{ stdenv, rustPlatform, dbus, pkgconfig, ... }:
2
3rustPlatform.buildRustPackage rec {
4 name = "set_eq-${version}";
5 version = "0.1.0";
6
7 buildInputs = [ dbus pkgconfig ];
8
9 src = ./.;
10 cargoSha256 = "0lknxqr1pfbj6z981rw5ppkklknryyafl5f552aaw4iqhq94slq4";
11
12 meta = with stdenv.lib; {
13 description = "A command-line tool to manipulate PulseAudio's equalizer";
14 homepage = https://github.com/minijackson/set_eq;
15 platforms = platforms.all;
16 };
17}