summaryrefslogtreecommitdiffstats
path: root/lua-bindings/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'lua-bindings/Cargo.toml')
-rw-r--r--lua-bindings/Cargo.toml15
1 files changed, 15 insertions, 0 deletions
diff --git a/lua-bindings/Cargo.toml b/lua-bindings/Cargo.toml
new file mode 100644
index 0000000..3859c4e
--- /dev/null
+++ b/lua-bindings/Cargo.toml
@@ -0,0 +1,15 @@
1[package]
2name = "diaphragm-lua-bindings"
3version = "0.1.0"
4edition = "2021"
5
6[lib]
7crate-type = ["cdylib"]
8name = "diaphragm"
9
10[dependencies]
11diaphragm-core = { path = "../core" }
12diaphragm-z3-solver = { path = "../z3-solver" }
13diaphragm-cairo-renderer = { path = "../cairo-renderer" }
14
15mlua = { version = "0.8", features = ["lua54", "module"] }