summaryrefslogtreecommitdiffstats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..bbe2ab1
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,22 @@
1{
2 inputs.nixpkgs.url = "github:NixOS/nixpkgs/nixos-22.11";
3
4 outputs = {
5 self,
6 nixpkgs,
7 }: let
8 pkgs = nixpkgs.legacyPackages.x86_64-linux;
9 in {
10 devShell.x86_64-linux = pkgs.mkShell {
11 buildInputs = with pkgs; [
12 pkgconfig
13 cairo
14 pango
15 z3
16
17 lua5_4
18 stylua
19 ];
20 };
21 };
22}