summaryrefslogtreecommitdiffstats
path: root/usecases/desktop/graphical/zathura.nix
diff options
context:
space:
mode:
Diffstat (limited to 'usecases/desktop/graphical/zathura.nix')
-rw-r--r--usecases/desktop/graphical/zathura.nix55
1 files changed, 55 insertions, 0 deletions
diff --git a/usecases/desktop/graphical/zathura.nix b/usecases/desktop/graphical/zathura.nix
new file mode 100644
index 0000000..d1832d8
--- /dev/null
+++ b/usecases/desktop/graphical/zathura.nix
@@ -0,0 +1,55 @@
1inputs:
2
3{ config, ... }:
4
5{
6 home-manager.users.minijackson.programs.zathura = {
7 enable = true;
8
9 options = with config.theme.colors; {
10 guioptions = "";
11 adjust-open = "width";
12
13 smooth-scroll = true;
14 scroll-step = 100;
15 #scroll-full-overlap = 0.05;
16
17 selection-clipboard = "clipboard";
18
19 default-bg = softBackground;
20 default-fg = foreground;
21
22 notification-error-bg = neutralRed;
23 notification-error-fg = foreground;
24
25 notification-warning-bg = background;
26 notification-warning-fg = brightRed;
27
28 highlight-color = fadedYellow;
29 highlight-active-color = brightYellow;
30
31 inputbar-bg = background;
32 inputbar-fg = dominant;
33
34 completion-bg = background;
35 completion-fg = neutralBlue;
36
37 completion-highlight-bg = dominant;
38 completion-highlight-fg = background;
39
40 notification-bg = dominant;
41 notification-fg = background;
42
43 index-bg = background;
44 index-fg = foreground;
45
46 index-active-bg = dominant;
47 index-active-fg = background;
48
49 recolor-lightcolor = background;
50 recolor-darkcolor = foreground;
51 recolor-keephue = true;
52 recolor = true;
53 };
54 };
55}