diff options
Diffstat (limited to 'usecases/desktop/graphical/waybar.nix')
-rw-r--r-- | usecases/desktop/graphical/waybar.nix | 164 |
1 files changed, 81 insertions, 83 deletions
diff --git a/usecases/desktop/graphical/waybar.nix b/usecases/desktop/graphical/waybar.nix index e9a227a..84fa694 100644 --- a/usecases/desktop/graphical/waybar.nix +++ b/usecases/desktop/graphical/waybar.nix | |||
@@ -30,104 +30,102 @@ inputs: | |||
30 | "tray" | 30 | "tray" |
31 | ]; | 31 | ]; |
32 | 32 | ||
33 | modules = { | 33 | mpd = lib.mkIf config.services.mpd.enable { |
34 | mpd = lib.mkIf config.services.mpd.enable { | 34 | format = "{stateIcon} {consumeIcon}{randomIcon}{repeatIcon}{singleIcon}{artist} - {album} - {title} ({elapsedTime:%M:%S}/{totalTime:%M:%S}) <span font_desc='Font Awesome 5 Free'></span>"; |
35 | format = "{stateIcon} {consumeIcon}{randomIcon}{repeatIcon}{singleIcon}{artist} - {album} - {title} ({elapsedTime:%M:%S}/{totalTime:%M:%S}) <span font_desc='Font Awesome 5 Free'></span>"; | 35 | format-stopped = "{consumeIcon}{randomIcon}{repeatIcon}{singleIcon}Stopped <span font_desc='Font Awesome 5 Free'></span>"; |
36 | format-stopped = "{consumeIcon}{randomIcon}{repeatIcon}{singleIcon}Stopped <span font_desc='Font Awesome 5 Free'></span>"; | 36 | format-disconnected = "Disconnected <span font_desc='Font Awesome 5 Free'></span>"; |
37 | format-disconnected = "Disconnected <span font_desc='Font Awesome 5 Free'></span>"; | ||
38 | |||
39 | on-click-middle = "${pkgs.alacritty}/bin/alacritty --command ncmpcpp"; | ||
40 | |||
41 | consume-icons = { | ||
42 | on = " "; | ||
43 | }; | ||
44 | |||
45 | random-icons = { | ||
46 | on = " "; | ||
47 | }; | ||
48 | |||
49 | repeat-icons = { | ||
50 | on = " "; | ||
51 | }; | ||
52 | |||
53 | single-icons = { | ||
54 | on = "1 "; | ||
55 | }; | ||
56 | |||
57 | state-icons = { | ||
58 | playing = ""; | ||
59 | paused = ""; | ||
60 | }; | ||
61 | }; | ||
62 | 37 | ||
63 | idle_inhibitor = { | 38 | on-click-middle = "${pkgs.alacritty}/bin/alacritty --command ncmpcpp"; |
64 | format = "{icon}"; | ||
65 | format-icons = { | ||
66 | activated = ""; | ||
67 | deactivated = ""; | ||
68 | }; | ||
69 | }; | ||
70 | 39 | ||
71 | clock = { | 40 | consume-icons = { |
72 | tooltip-format = "{:%Y-%m-%d | %H:%M}"; | 41 | on = " "; |
73 | format-alt = "{:%Y-%m-%d}"; | ||
74 | }; | 42 | }; |
75 | 43 | ||
76 | cpu = { format = "{usage}% "; }; | 44 | random-icons = { |
77 | 45 | on = " "; | |
78 | memory = { format = "{}% "; }; | ||
79 | |||
80 | battery = { | ||
81 | states = { good = 90; }; | ||
82 | format = "{capacity}% {icon}"; | ||
83 | format-icons = [ | ||
84 | "<span font_desc='Font Awesome 5 Free'></span>" | ||
85 | "<span font_desc='Font Awesome 5 Free'></span>" | ||
86 | "<span font_desc='Font Awesome 5 Free'></span>" | ||
87 | "<span font_desc='Font Awesome 5 Free'></span>" | ||
88 | "<span font_desc='Font Awesome 5 Free'></span>" | ||
89 | ]; | ||
90 | }; | 46 | }; |
91 | 47 | ||
92 | "network#eth" = { | 48 | repeat-icons = { |
93 | interface = "enp*"; | 49 | on = " "; |
94 | format-ethernet = "{ipaddr}/{cidr} "; | ||
95 | format-disconnected = "Disconnected "; | ||
96 | }; | 50 | }; |
97 | 51 | ||
98 | "network#wlan" = { | 52 | single-icons = { |
99 | interface = "wlp*"; | 53 | on = "1 "; |
100 | format-wifi = "{essid} ({signalStrength}%) <span font_desc='Font Awesome 5 Free'></span>"; | ||
101 | format-disconnected = "Disconnected <span font_desc='Font Awesome 5 Free'></span>"; | ||
102 | tooltip = true; | ||
103 | tooltip-format-wifi = "{ipaddr}/{cidr}"; | ||
104 | }; | 54 | }; |
105 | 55 | ||
106 | temperature = { | 56 | state-icons = { |
107 | hwmon-path = "/sys/class/hwmon/hwmon0/temp1_input"; | 57 | playing = ""; |
108 | format = "{temperatureC} °C "; | 58 | paused = ""; |
109 | }; | 59 | }; |
60 | }; | ||
110 | 61 | ||
111 | backlight = { | 62 | idle_inhibitor = { |
112 | format = "{percent}% <span font_desc='Font Awesome 5 Free'>{icon}</span>"; | 63 | format = "{icon}"; |
113 | format-icons = [ "" "" ]; | 64 | format-icons = { |
65 | activated = ""; | ||
66 | deactivated = ""; | ||
114 | }; | 67 | }; |
68 | }; | ||
69 | |||
70 | clock = { | ||
71 | tooltip-format = "{:%Y-%m-%d | %H:%M}"; | ||
72 | format-alt = "{:%Y-%m-%d}"; | ||
73 | }; | ||
74 | |||
75 | cpu = { format = "{usage}% "; }; | ||
76 | |||
77 | memory = { format = "{}% "; }; | ||
78 | |||
79 | battery = { | ||
80 | states = { good = 90; }; | ||
81 | format = "{capacity}% {icon}"; | ||
82 | format-icons = [ | ||
83 | "<span font_desc='Font Awesome 5 Free'></span>" | ||
84 | "<span font_desc='Font Awesome 5 Free'></span>" | ||
85 | "<span font_desc='Font Awesome 5 Free'></span>" | ||
86 | "<span font_desc='Font Awesome 5 Free'></span>" | ||
87 | "<span font_desc='Font Awesome 5 Free'></span>" | ||
88 | ]; | ||
89 | }; | ||
90 | |||
91 | "network#eth" = { | ||
92 | interface = "enp*"; | ||
93 | format-ethernet = "{ipaddr}/{cidr} "; | ||
94 | format-disconnected = "Disconnected "; | ||
95 | }; | ||
96 | |||
97 | "network#wlan" = { | ||
98 | interface = "wlp*"; | ||
99 | format-wifi = "{essid} ({signalStrength}%) <span font_desc='Font Awesome 5 Free'></span>"; | ||
100 | format-disconnected = "Disconnected <span font_desc='Font Awesome 5 Free'></span>"; | ||
101 | tooltip = true; | ||
102 | tooltip-format-wifi = "{ipaddr}/{cidr}"; | ||
103 | }; | ||
104 | |||
105 | temperature = { | ||
106 | hwmon-path = "/sys/class/hwmon/hwmon0/temp1_input"; | ||
107 | format = "{temperatureC} °C "; | ||
108 | }; | ||
109 | |||
110 | backlight = { | ||
111 | format = "{percent}% <span font_desc='Font Awesome 5 Free'>{icon}</span>"; | ||
112 | format-icons = [ "" "" ]; | ||
113 | }; | ||
115 | 114 | ||
116 | pulseaudio = { | 115 | pulseaudio = { |
117 | format = "{volume}% {icon}"; | 116 | format = "{volume}% {icon}"; |
118 | format-bluetooth = "{volume}% {icon}"; | 117 | format-bluetooth = "{volume}% {icon}"; |
119 | format-muted = ""; | 118 | format-muted = ""; |
120 | format-icons = { | 119 | format-icons = { |
121 | headphones = ""; | 120 | headphones = ""; |
122 | handsfree = ""; | 121 | handsfree = ""; |
123 | headset = ""; | 122 | headset = ""; |
124 | phone = ""; | 123 | phone = ""; |
125 | portable = ""; | 124 | portable = ""; |
126 | car = ""; | 125 | car = ""; |
127 | default = [ "" "" ]; | 126 | default = [ "" "" ]; |
128 | }; | ||
129 | on-click = "pavucontrol"; | ||
130 | }; | 127 | }; |
128 | on-click = "pavucontrol"; | ||
131 | }; | 129 | }; |
132 | }]; | 130 | }]; |
133 | 131 | ||