diff options
Diffstat (limited to 'usecases/desktop/graphical/swaync.nix')
-rw-r--r-- | usecases/desktop/graphical/swaync.nix | 47 |
1 files changed, 47 insertions, 0 deletions
diff --git a/usecases/desktop/graphical/swaync.nix b/usecases/desktop/graphical/swaync.nix new file mode 100644 index 0000000..34b7dba --- /dev/null +++ b/usecases/desktop/graphical/swaync.nix | |||
@@ -0,0 +1,47 @@ | |||
1 | { config, lib, ... }: | ||
2 | let | ||
3 | cfg = config.reborn.swaync; | ||
4 | in | ||
5 | { | ||
6 | options.reborn.swaync = { | ||
7 | enable = lib.mkEnableOption "Reborn swaync config"; | ||
8 | }; | ||
9 | |||
10 | config = lib.mkIf cfg.enable { | ||
11 | home-manager.users.minijackson.services.swaync = { | ||
12 | enable = true; | ||
13 | |||
14 | settings = { | ||
15 | widgets = [ | ||
16 | "buttons-grid" | ||
17 | "mpris" | ||
18 | "volume" | ||
19 | "backlight" | ||
20 | "inhibitors" | ||
21 | "title" | ||
22 | "dnd" | ||
23 | "notifications" | ||
24 | ]; | ||
25 | widget-config = { | ||
26 | buttons-grid.actions = [ | ||
27 | { | ||
28 | label = ""; | ||
29 | command = "systemctl reboot"; | ||
30 | } | ||
31 | { | ||
32 | label = ""; | ||
33 | command = "systemctl poweroff"; | ||
34 | } | ||
35 | ]; | ||
36 | volume = { | ||
37 | label = ""; | ||
38 | show-per-app = true; | ||
39 | show-per-app-label = true; | ||
40 | }; | ||
41 | }; | ||
42 | }; | ||
43 | |||
44 | style = ./swaync.css; | ||
45 | }; | ||
46 | }; | ||
47 | } | ||