summaryrefslogtreecommitdiffstats
path: root/usecases/desktop/graphical/swaylock.nix
diff options
context:
space:
mode:
Diffstat (limited to 'usecases/desktop/graphical/swaylock.nix')
-rw-r--r--usecases/desktop/graphical/swaylock.nix65
1 files changed, 65 insertions, 0 deletions
diff --git a/usecases/desktop/graphical/swaylock.nix b/usecases/desktop/graphical/swaylock.nix
new file mode 100644
index 0000000..6dc7683
--- /dev/null
+++ b/usecases/desktop/graphical/swaylock.nix
@@ -0,0 +1,65 @@
1{ config, lib, ... }:
2let
3 cfg = config.reborn.swaylock;
4in
5{
6 options.reborn.swaylock = {
7 enable = lib.mkEnableOption "Reborn swaylock config";
8 };
9
10 config = lib.mkIf cfg.enable {
11 home-manager.users.minijackson.programs.swaylock = {
12 enable = true;
13 settings =
14 let
15 inherit (config.theme.colors)
16 background
17 brightGreen
18 brightOrange
19 brightRed
20 dominant
21 neutralOrange
22 neutralRed
23 ;
24 in
25 {
26 ignore-empty-password = true;
27 show-failed-attempts = true;
28
29 image = "${../../../res/wallpapers/wallpaper-1920x1080-install-gentoo.png}";
30
31 font = "monospace";
32
33 inside-color = "${lib.removePrefix "#" dominant}dd";
34 inside-clear-color = "${lib.removePrefix "#" neutralOrange}dd";
35 inside-ver-color = "${lib.removePrefix "#" neutralOrange}dd";
36 inside-wrong-color = "${lib.removePrefix "#" neutralRed}dd";
37
38 key-hl-color = "${lib.removePrefix "#" brightGreen}ee";
39 bs-hl-color = "${lib.removePrefix "#" neutralRed}ee";
40
41 line-color = "${lib.removePrefix "#" background}ee";
42 line-clear-color = "${lib.removePrefix "#" background}ee";
43 line-ver-color = "${lib.removePrefix "#" background}ee";
44 line-wrong-color = "${lib.removePrefix "#" background}ee";
45
46 ring-color = "${lib.removePrefix "#" dominant}ee";
47 ring-clear-color = "${lib.removePrefix "#" brightOrange}ee";
48 ring-ver-color = "${lib.removePrefix "#" brightOrange}ee";
49 ring-wrong-color = "${lib.removePrefix "#" brightRed}ee";
50
51 separator-color = "${lib.removePrefix "#" background}ee";
52
53 text-color = "${lib.removePrefix "#" background}ff";
54 text-clear-color = "${lib.removePrefix "#" background}ff";
55 text-ver-color = "${lib.removePrefix "#" background}ff";
56 text-wrong-color = "${lib.removePrefix "#" background}ff";
57
58 indicator-radius = 75;
59 indicator-thickness = 10;
60 };
61 };
62
63 security.pam.services.swaylock = { };
64 };
65}