summaryrefslogtreecommitdiffstats
path: root/usecases/desktop/graphical/rofi.nix
diff options
context:
space:
mode:
Diffstat (limited to 'usecases/desktop/graphical/rofi.nix')
-rw-r--r--usecases/desktop/graphical/rofi.nix16
1 files changed, 14 insertions, 2 deletions
diff --git a/usecases/desktop/graphical/rofi.nix b/usecases/desktop/graphical/rofi.nix
index e43d461..741e7da 100644
--- a/usecases/desktop/graphical/rofi.nix
+++ b/usecases/desktop/graphical/rofi.nix
@@ -6,7 +6,10 @@ _inputs: {
6 home-manager.users.minijackson.programs.rofi = { 6 home-manager.users.minijackson.programs.rofi = {
7 enable = true; 7 enable = true;
8 8
9 package = with pkgs; rofi-wayland.override {plugins = [rofi-emoji];}; 9 plugins = with pkgs; [
10 rofi-emoji
11 rofi-calc
12 ];
10 13
11 # TODO: there is a better way 14 # TODO: there is a better way
12 theme = with config.theme.colors; 15 theme = with config.theme.colors;
@@ -36,7 +39,7 @@ _inputs: {
36 } 39 }
37 40
38 mainbox { 41 mainbox {
39 children: [inputbar, listview]; 42 children: [inputbar, message, listview];
40 border: 1px solid; 43 border: 1px solid;
41 border-color: ${dimForeground}; 44 border-color: ${dimForeground};
42 } 45 }
@@ -58,6 +61,15 @@ _inputs: {
58 padding: 12px 0; 61 padding: 12px 0;
59 } 62 }
60 63
64 message {
65 padding: 12px;
66 background-color: ${background2};
67 }
68
69 textbox {
70 background-color: inherit;
71 }
72
61 entry { 73 entry {
62 background-color: inherit; 74 background-color: inherit;
63 padding: 12px 0; 75 padding: 12px 0;