summaryrefslogtreecommitdiffstats
path: root/usecases/desktop/graphical.nix
diff options
context:
space:
mode:
Diffstat (limited to 'usecases/desktop/graphical.nix')
-rw-r--r--usecases/desktop/graphical.nix62
1 files changed, 4 insertions, 58 deletions
diff --git a/usecases/desktop/graphical.nix b/usecases/desktop/graphical.nix
index 8251a50..cee9186 100644
--- a/usecases/desktop/graphical.nix
+++ b/usecases/desktop/graphical.nix
@@ -7,6 +7,7 @@ inputs: {
7 imports = [ 7 imports = [
8 (import ./graphical/alacritty.nix inputs) 8 (import ./graphical/alacritty.nix inputs)
9 (import ./graphical/firefox.nix inputs) 9 (import ./graphical/firefox.nix inputs)
10 (import ./graphical/gtk.nix inputs)
10 (import ./graphical/mpv.nix inputs) 11 (import ./graphical/mpv.nix inputs)
11 (import ./graphical/rofi.nix inputs) 12 (import ./graphical/rofi.nix inputs)
12 (import ./graphical/sway.nix inputs) 13 (import ./graphical/sway.nix inputs)
@@ -105,63 +106,8 @@ inputs: {
105 } 106 }
106 ]; 107 ];
107 108
108 home-manager.users.minijackson = let 109 home-manager.users.minijackson.services.kdeconnect = {
109 color = 110 enable = true;
110 if config.theme.colors.dominantName == "cyan" 111 indicator = true;
111 then "teal"
112 else config.theme.colors.dominantName;
113 in {
114 gtk = {
115 enable = true;
116 iconTheme = {
117 # TODO: properly modify the colors
118 package = pkgs.unstable.tela-circle-icon-theme.override {
119 colorVariants = ["brown"];
120 };
121 name = "Tela-circle-brown-dark";
122 };
123
124 theme = {
125 package = pkgs.gnome.gnome-themes-extra;
126 name = "Adwaita-dark";
127 };
128
129 # theme = {
130 # package =
131 # (pkgs.unstable.graphite-gtk-theme.overrideAttrs (_old: {
132 # src = pkgs.fetchFromGitHub {
133 # owner = "vinceliuice";
134 # repo = "graphite-gtk-theme";
135 # rev = "a65fbec34f1ba1e9c7f7a86afc7c02d2210a11a4";
136 # hash = "sha256-aJMSLWVDqsAx+3QYAAhGKddEaformlK28M7YSJ/v7sU=";
137 # };
138 # }))
139 # .override {
140 # themeVariants = [color];
141 # sizeVariants = ["compact"];
142 # tweaks = ["normal" "rimless"];
143 # };
144 # name = "Graphite-${color}-Dark-compact";
145 # };
146
147 # gtk4.extraConfig = {
148 # gtk-application-prefer-dark-theme = true;
149 # };
150
151 gtk3.extraConfig.gtk-application-prefer-dark-theme = true;
152 };
153
154 dconf.settings = {
155 "org/gnome/desktop/interface" = {
156 color-scheme = "prefer-dark";
157 };
158 };
159
160 # home.sessionVariables.GTK_THEME = "Graphite-${color}-Dark-compact";
161
162 services.kdeconnect = {
163 enable = true;
164 indicator = true;
165 };
166 }; 112 };
167} 113}